summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-16 06:20:21 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-16 06:50:16 +0100
commit772147d81522e8c9d7b7cc0a0c5e1757030f7c87 (patch)
treed997d4a7ce255d2f8126833845a91477571a085b /dev-python/flask-babel
parentnet-misc/ytfzf: add 2.5.4 unkeyworded (diff)
downloadgentoo-772147d81522e8c9d7b7cc0a0c5e1757030f7c87.tar.gz
gentoo-772147d81522e8c9d7b7cc0a0c5e1757030f7c87.tar.bz2
gentoo-772147d81522e8c9d7b7cc0a0c5e1757030f7c87.zip
dev-python/flask-babel: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-babel')
-rw-r--r--dev-python/flask-babel/Manifest1
-rw-r--r--dev-python/flask-babel/flask-babel-3.0.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/flask-babel/Manifest b/dev-python/flask-babel/Manifest
index af1ebc3b96f7..a8df930aabdf 100644
--- a/dev-python/flask-babel/Manifest
+++ b/dev-python/flask-babel/Manifest
@@ -1 +1,2 @@
DIST Flask-Babel-2.0.0.tar.gz 19588 BLAKE2B dbd5d6f3af38fad15a4eb6d674222473d673a9002ced21ce09a913e0bce3285b1eac9a5a85ce53c1dcebf648444164f33a5c790039a7d01184d45c7734dac05f SHA512 2ad8f80b450db0cab7dd57f46158e7e653556d60869acdb3c2469d42dceca3fa97237cc960986655091c84a1a67a057d72ed510787ccb065d171e6f35764cb1d
+DIST flask-babel-3.0.0.gh.tar.gz 20354 BLAKE2B feed1728f4083b1a421010e7ff8aa8b8362f8c9b54556e4d3268e4028b7a51a1364c8c5f13b07585af6e9382e903b66420797cf4c9bf29736870963120d0502a SHA512 a7f93047e82a0383aaa4114bcb626a9e08ed15e450c43e3a09198f75c02f501dfa6e2b8157c618cb8d19f94e76d93f8e826adc99bd146abeee85837d2618da86
diff --git a/dev-python/flask-babel/flask-babel-3.0.0.ebuild b/dev-python/flask-babel/flask-babel-3.0.0.ebuild
new file mode 100644
index 000000000000..7dd80d01352b
--- /dev/null
+++ b/dev-python/flask-babel/flask-babel-3.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="i18n and l10n support for Flask based on Babel and pytz"
+HOMEPAGE="
+ https://python-babel.github.io/flask-babel/
+ https://github.com/python-babel/flask-babel/
+ https://pypi.org/project/Flask-Babel/
+"
+SRC_URI="
+ https://github.com/python-babel/flask-babel/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/Babel-3[${PYTHON_USEDEP}]
+ <dev-python/flask-3[${PYTHON_USEDEP}]
+ <dev-python/jinja-4[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/pallets-sphinx-themes
+distutils_enable_tests pytest