summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-06-19 23:37:25 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-06-19 23:39:34 +0200
commit5f16bc2acda903e79d7ed27b6c2e0445f64fffd6 (patch)
tree19821657a8e4ea22933b0a15415d1d50517d4b57 /dev-python/flask-appconfig
parentsys-boot/shim: sssssh (diff)
downloadgentoo-5f16bc2acda903e79d7ed27b6c2e0445f64fffd6.tar.gz
gentoo-5f16bc2acda903e79d7ed27b6c2e0445f64fffd6.tar.bz2
gentoo-5f16bc2acda903e79d7ed27b6c2e0445f64fffd6.zip
dev-python/flask-appconfig: Add Python 3.6, PyPy{,3}
Also remove useless depend on pytest-runner. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/flask-appconfig')
-rw-r--r--dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild b/dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild
index 66d2f6d35180..2e1c7689325f 100644
--- a/dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild
+++ b/dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
inherit distutils-r1
@@ -24,12 +24,11 @@ RDEPEND="
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
)
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
python_prepare_all() {
@@ -40,14 +39,12 @@ python_prepare_all() {
}
python_compile_all() {
- use doc && emake -C docs html
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
}
python_test() {
py.test || die "Tests failed with ${EPYTHON}"
}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}