summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-06 11:11:46 +0100
committerMichał Górny <mgorny@gentoo.org>2021-05-06 13:20:12 +0200
commit7415489e96010d4b397bae6ae8df7b38cd4245f6 (patch)
tree6ed84f2444ecd2433dd0b9d0970603fe9b4a492d /dev-python/entrypoints
parentdev-python/aesara: Remove old (diff)
downloadgentoo-7415489e96010d4b397bae6ae8df7b38cd4245f6.tar.gz
gentoo-7415489e96010d4b397bae6ae8df7b38cd4245f6.tar.bz2
gentoo-7415489e96010d4b397bae6ae8df7b38cd4245f6.zip
dev-python/entrypoints: Port to python3.10
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/entrypoints')
-rw-r--r--dev-python/entrypoints/entrypoints-0.3-r2.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/dev-python/entrypoints/entrypoints-0.3-r2.ebuild b/dev-python/entrypoints/entrypoints-0.3-r2.ebuild
index 1504f0a9b347..2410523b9886 100644
--- a/dev-python/entrypoints/entrypoints-0.3-r2.ebuild
+++ b/dev-python/entrypoints/entrypoints-0.3-r2.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
-
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Discover and load entry points from installed packages"
@@ -15,15 +14,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
+distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}/${PN}"-0.2.1-init.py.patch