summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-29 09:25:44 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-29 09:28:18 +0200
commitaaf113d8586f42cb084ec4ba3b86284c4fb77574 (patch)
treef8f5248bfc45a380340504a188515c45fc81539c /dev-python/enable/enable-4.4.1.ebuild
parentdev-python/pyasn1: Version Bump (diff)
downloadgentoo-aaf113d8586f42cb084ec4ba3b86284c4fb77574.tar.gz
gentoo-aaf113d8586f42cb084ec4ba3b86284c4fb77574.tar.bz2
gentoo-aaf113d8586f42cb084ec4ba3b86284c4fb77574.zip
dev-python/enable: Version Bump and fix for newer swig
backport fix for newer swig Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=561752 Package-Manager: portage-2.2.22 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/enable/enable-4.4.1.ebuild')
-rw-r--r--dev-python/enable/enable-4.4.1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/enable/enable-4.4.1.ebuild b/dev-python/enable/enable-4.4.1.ebuild
index ae98e27977f0..e34d454e13b1 100644
--- a/dev-python/enable/enable-4.4.1.ebuild
+++ b/dev-python/enable/enable-4.4.1.ebuild
@@ -3,21 +3,22 @@
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 virtualx flag-o-matic
DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
-HOMEPAGE="http://code.enthought.com/projects/enable/ https://pypi.python.org/pypi/enable"
-SRC_URI="https://github.com/enthought/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://code.enthought.com/projects/enable/ https://pypi.python.org/pypi/enable https://github.com/enthought/enable"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
-DISTUTILS_IN_SOURCE_BUILD=1
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
dev-python/reportlab[${PYTHON_USEDEP}]
>=dev-python/traitsui-4[${PYTHON_USEDEP}]
>=media-libs/freetype-2
@@ -35,6 +36,10 @@ DEPEND="${RDEPEND}
media-fonts/font-misc-misc
)"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}"/${P}-swig.patch )
+
python_prepare_all() {
append-cflags -fno-strict-aliasing