summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-05 07:16:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-05 07:21:15 +0200
commita344a53effcb0df0dbf1b33c87ca42869bde73b9 (patch)
tree3d6b45452aa62f03f6a9f1d381d2a00ef515554c /dev-python/elementpath
parentnet-misc/electrum: Bump to 4.4.2 (diff)
downloadgentoo-a344a53effcb0df0dbf1b33c87ca42869bde73b9.tar.gz
gentoo-a344a53effcb0df0dbf1b33c87ca42869bde73b9.tar.bz2
gentoo-a344a53effcb0df0dbf1b33c87ca42869bde73b9.zip
dev-python/elementpath: Bump to 4.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-4.1.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index d76b900ce298..155d370b71dd 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1 +1,2 @@
DIST elementpath-4.1.1.tar.gz 318449 BLAKE2B 3e472ad273a64926a3f63038d2cf5a480bf96f1af96675c23e5c3d2208e72a75f4478e10b82c8956509414c477473ec45163e8df58844dd5702804c65668d61f SHA512 95f2c238404718ff425d3f6be727a2620f519ecf41036c03148184225e968ce3b26a0c8247bf30eb1e0a8883febfc604ff38fa01c573cd26b81bd90ac79f6eed
+DIST elementpath-4.1.2.tar.gz 320962 BLAKE2B 39ad80033022119159bcc89e6ea06f23de7d6c0cfca7e63f64ac01fa0e4c36a8d3091cc57efdfc7d5efb735ee058d2ed25abd15ae5297b65a8efdfe4413e4ffc SHA512 f6ab5905986fab88398e9a3774460069f610234126649299228f86020bee48f3d98be90434a4f662b371ef0051e80147df0a0f323e7095fedcab8567237c2c00
diff --git a/dev-python/elementpath/elementpath-4.1.2.ebuild b/dev-python/elementpath/elementpath-4.1.2.ebuild
new file mode 100644
index 000000000000..55532d1d5a5e
--- /dev/null
+++ b/dev-python/elementpath/elementpath-4.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="
+ https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fails for some reason, more fit for upstream testing anyway
+ rm tests/test_typing.py || die
+ distutils-r1_src_prepare
+}