summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-12 09:36:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-12 09:42:45 +0200
commitd4de8488b974998d5063f1c7ce331b6420c24824 (patch)
tree75d0c32b6bced0f76f3902718b81067956b171f8 /dev-python/elasticsearch
parentdev-python/netaddr: Remove old (diff)
downloadgentoo-d4de8488b974998d5063f1c7ce331b6420c24824.tar.gz
gentoo-d4de8488b974998d5063f1c7ce331b6420c24824.tar.bz2
gentoo-d4de8488b974998d5063f1c7ce331b6420c24824.zip
dev-python/elasticsearch: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elasticsearch')
-rw-r--r--dev-python/elasticsearch/Manifest1
-rw-r--r--dev-python/elasticsearch/elasticsearch-8.13.1.ebuild83
2 files changed, 0 insertions, 84 deletions
diff --git a/dev-python/elasticsearch/Manifest b/dev-python/elasticsearch/Manifest
index f0bfe58562c8..2bd765fdf223 100644
--- a/dev-python/elasticsearch/Manifest
+++ b/dev-python/elasticsearch/Manifest
@@ -1,2 +1 @@
-DIST elasticsearch-py-8.13.1.gh.tar.gz 1074911 BLAKE2B 4ba5f728690274ab074fa17993c59fb41d4493bc05b69d4281db56c274ddd522124c96046248bdecf7fc362e624853d7a31fac0a12d952faf0e38296d62c89c9 SHA512 ab5b3b67e70588c31a2b62fe03dd5aa0320da36b4a669986207db5982fabfb8fa800d181be958505bb264a9fb72ab33a9d5167779300e93d0874e9105e990891
DIST elasticsearch-py-8.13.2.gh.tar.gz 1075234 BLAKE2B a13126b41f297db196b0ad22ff1da419e3472d42314984133380f0826d25a2e5ba5e0dcd0a9d571e8e27382eb53ceeadd32a4b6de312e63a3b192fd27829495d SHA512 c5f59eee672da292ca7f40e894a88c62bee3aabf35eb241c48f8f9a52c81e2348747e7d09d3b3323575407c8a072f510dffca2dce2caf9e420a9b40d5e4582fc
diff --git a/dev-python/elasticsearch/elasticsearch-8.13.1.ebuild b/dev-python/elasticsearch/elasticsearch-8.13.1.ebuild
deleted file mode 100644
index 0d52bab441a9..000000000000
--- a/dev-python/elasticsearch/elasticsearch-8.13.1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{11..12} )
-
-inherit distutils-r1
-
-MY_P="elasticsearch-py-${PV}"
-DESCRIPTION="Official Elasticsearch client library for Python"
-HOMEPAGE="
- https://ela.st/es-python
- https://github.com/elastic/elasticsearch-py/
- https://pypi.org/project/elasticsearch/
-"
-SRC_URI="
- https://github.com/elastic/elasticsearch-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0/$(ver_cut 1)"
-KEYWORDS="amd64 arm64 ~x86"
-
-RDEPEND="
- <dev-python/aiohttp-4[${PYTHON_USEDEP}]
- >=dev-python/aiohttp-3[${PYTHON_USEDEP}]
- <dev-python/elastic-transport-9[${PYTHON_USEDEP}]
- >=dev-python/elastic-transport-8.13[${PYTHON_USEDEP}]
- >=dev-python/orjson-3[${PYTHON_USEDEP}]
- <dev-python/requests-3[${PYTHON_USEDEP}]
- >=dev-python/requests-2.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/mapbox-vector-tile[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/opentelemetry-api[${PYTHON_USEDEP}]
- dev-python/opentelemetry-sdk[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
- dev-python/unasync[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/sphinx \
- dev-python/sphinx-autodoc-typehints \
- dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-src_prepare() {
- # https://github.com/elastic/elasticsearch-py/pull/2552/
- sed -i -e '/float_/d' elasticsearch/serializer.py \
- test_elasticsearch/test_serializer.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_IGNORE=(
- # REST api tests are a black hole for effort. It downloads the tests
- # so its an ever moving target. It also requires effort to blacklist
- # tests for apis which are license restricted.
- "test_elasticsearch/test_server/test_rest_api_spec.py"
- # Counting deprecation warnings from python is bound to fail even
- # if all are fixed in this package. Not worth it.
- "test_elasticsearch/test_client/test_deprecated_options.py"
- # Running daemon for tests is finicky and upstream CI fails at it
- # as well.
- "test_elasticsearch/test_server/"
- "test_elasticsearch/test_async/test_server/"
- )
-
- local -x TEST_WITH_OTEL=1
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -o addopts= -p asyncio
-}