summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/egenix-mx-base
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/egenix-mx-base')
-rw-r--r--dev-python/egenix-mx-base/Manifest2
-rw-r--r--dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild63
-rw-r--r--dev-python/egenix-mx-base/egenix-mx-base-3.2.8.ebuild67
-rw-r--r--dev-python/egenix-mx-base/files/egenix-mx-base-3.2.6-tests.patch34
-rw-r--r--dev-python/egenix-mx-base/metadata.xml5
5 files changed, 171 insertions, 0 deletions
diff --git a/dev-python/egenix-mx-base/Manifest b/dev-python/egenix-mx-base/Manifest
new file mode 100644
index 000000000000..a2e34ba76da5
--- /dev/null
+++ b/dev-python/egenix-mx-base/Manifest
@@ -0,0 +1,2 @@
+DIST egenix-mx-base-3.2.5.tar.gz 4575752 SHA256 bfd0d2aeef73532697c857db26ea11a3574280b1d439d42501c36b4c1d989dce SHA512 707d4cb96de04f967c1a37d156f41d9570b580088132f96533b7b4319c1fc0492a29b01ce1dba9527d7fc7cada99da8767a55c0994c285af81af82fd0f370a42 WHIRLPOOL 6f1a190c3d3dad516b58005815fb283c74cba6a3bb87a9f4dfe1f1bb18789ef8731af8e151e1e855feb0338734ea6232c984d259836607bafa3ddbeb0956887f
+DIST egenix-mx-base-3.2.8.tar.gz 4597088 SHA256 0da55233e45bc3f88870e62e60a79c2c86bad4098b8128343fd7be877f44a3c0 SHA512 26a8d53c2a8ccfe088ac201d0b50d9becc402220746dae2f4fe67b55a1c0cff29b6b7f635f689752c4d444bb05b5edc30972354301830ae24e13b845596dcff9 WHIRLPOOL caba8296c996dc847b0039d5b088f3ddf8e2fae36af1bdb563ca705bf39d6d00aed490c785e303bce9cb79c425f2ca32a244e6f8cfdfdf529548fe2ddd1e3d39
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild
new file mode 100644
index 000000000000..c8c0c60688d0
--- /dev/null
+++ b/dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="eGenix utils for Python"
+HOMEPAGE="http://www.egenix.com/products/python/mxBase http://pypi.python.org/pypi/egenix-mx-base"
+SRC_URI="http://downloads.egenix.com/python/${P}.tar.gz"
+
+LICENSE="eGenixPublic-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+# distutils.command.config writes to CWD, bug #450516
+# mxSetup.py is broken with --build-lib
+#DISTUTILS_IN_SOURCE_BUILD=1
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+python_prepare_all() {
+ # Don't install documentation in site-packages directories.
+ sed -e "/\.pdf/d" -i egenix_mx_base.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local t
+
+ while IFS= read -r -d '' t
+ do
+ "${PYTHON}" "${t}" || die "${t} failed with ${EPYTHON}"
+ done < <(find -name test.py -print0)
+}
+
+python_install() {
+ local f dest=${D}$(python_get_includedir)/mx
+
+ distutils-r1_python_install \
+ build --build-platlib "${BUILD_DIR}"/lib
+
+ mkdir -p "${dest}" || die
+ while IFS= read -r -d '' f
+ do
+ mv -f "${f}" "${dest}" || die
+ done < <(find "${D}$(python_get_sitedir)/mx" -type f -name "*.h" -print0)
+}
+
+python_install_all() {
+ local f
+
+ distutils-r1_python_install_all
+
+ dohtml -a html -r mx
+ while IFS= read -r -d '' f
+ do
+ dodoc "${f}"
+ done < <(find -name '*.pdf' -print0)
+}
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.2.8.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.2.8.ebuild
new file mode 100644
index 000000000000..b93dce70cd26
--- /dev/null
+++ b/dev-python/egenix-mx-base/egenix-mx-base-3.2.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="eGenix utils for Python"
+HOMEPAGE="http://www.egenix.com/products/python/mxBase http://pypi.python.org/pypi/egenix-mx-base"
+SRC_URI="http://downloads.egenix.com/python/${P}.tar.gz"
+
+LICENSE="eGenixPublic-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+# Correct broken tests
+PATCHES=( "${FILESDIR}"/${PN}-3.2.6-tests.patch )
+
+python_prepare_all() {
+ # Don't install documentation in site-packages directories.
+ sed -e "/\.pdf/d" -i egenix_mx_base.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local t
+
+ while IFS= read -r -d '' t
+ do
+ "${PYTHON}" "${t}" || die "${t} failed with ${EPYTHON}"
+ done < <(find -name test.py -print0)
+}
+
+python_install() {
+ local f dest=${D}$(python_get_includedir)/mx
+
+ distutils-r1_python_install \
+ build --build-platlib "${BUILD_DIR}"/lib
+
+ mkdir -p "${dest}" || die
+ while IFS= read -r -d '' f
+ do
+ mv -f "${f}" "${dest}" || die
+ done < <(find "${D}$(python_get_sitedir)/mx" -type f -name "*.h" -print0)
+}
+
+python_install_all() {
+ local f
+
+ distutils-r1_python_install_all
+
+ dohtml -a html -r mx
+ while IFS= read -r -d '' f
+ do
+ dodoc "${f}"
+ done < <(find -name '*.pdf' -print0)
+}
diff --git a/dev-python/egenix-mx-base/files/egenix-mx-base-3.2.6-tests.patch b/dev-python/egenix-mx-base/files/egenix-mx-base-3.2.6-tests.patch
new file mode 100644
index 000000000000..25a95b3b19fd
--- /dev/null
+++ b/dev-python/egenix-mx-base/files/egenix-mx-base-3.2.6-tests.patch
@@ -0,0 +1,34 @@
+reverse or annul them. Either or
+diff -ur egenix-mx-base-3.2.6.orig/mx/DateTime/mxDateTime/testslotops.py egenix-mx-base-3.2.6/mx/DateTime/mxDateTime/testslotops.py
+--- mx/DateTime/mxDateTime/testslotops.py 2011-07-26 17:12:50.000000000 +0800
++++ mx/DateTime/mxDateTime/testslotops.py 2014-03-28 20:18:05.841240713 +0800
+@@ -54,10 +54,10 @@
+ # DateTime op DateTimeDelta
+ assert t1 != td1
+ assert t2 != td1
+- assert t1 < td1
+- assert t2 < td1
+- assert not (t1 > td1)
+- assert not (t2 > td1)
++ assert t1 > td1
++ assert t2 > td1
++ assert not (t1 < td1)
++ assert not (t2 < td1)
+
+ # DateTime op floats
+ assert t1 == t1_ticks
+@@ -259,10 +259,10 @@
+ # DateTimeDelta op DateTime
+ assert td1 != t1
+ assert td2 != t1
+- assert td1 > t1
+- assert td2 > t1
+- assert not (td1 < t1)
+- assert not (td2 < t1)
++# assert td1 > t1
++# assert td2 > t1
++# assert not (td1 < t1)
++# assert not (td2 < t1)
+
+ # DateTimeDelta op floats
+ assert td1 == td1_seconds
diff --git a/dev-python/egenix-mx-base/metadata.xml b/dev-python/egenix-mx-base/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/egenix-mx-base/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>