summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-11-27 12:22:57 +0100
committerLouis Sautier <sbraz@gentoo.org>2018-11-27 12:23:48 +0100
commit8d57de52bd8bef84e6496517eeedc7ef58d35f3c (patch)
treeaf1ff1127fcad5fd609a0d1b58ecb4e922cc202b /dev-python/dominate
parentsys-apps/ack: add amd64-fbsd keyword. (diff)
downloadgentoo-8d57de52bd8bef84e6496517eeedc7ef58d35f3c.tar.gz
gentoo-8d57de52bd8bef84e6496517eeedc7ef58d35f3c.tar.bz2
gentoo-8d57de52bd8bef84e6496517eeedc7ef58d35f3c.zip
dev-python/dominate: bump to 2.3.5
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/dominate')
-rw-r--r--dev-python/dominate/Manifest1
-rw-r--r--dev-python/dominate/dominate-2.3.5.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/dominate/Manifest b/dev-python/dominate/Manifest
index a72183770eb2..fae64168b4ed 100644
--- a/dev-python/dominate/Manifest
+++ b/dev-python/dominate/Manifest
@@ -1,2 +1,3 @@
DIST dominate-2.3.1.tar.gz 27887 BLAKE2B 3ac0820bd0cb79e648dc947d3cb69aa207e3c129cbae05daaca8fd3a6e22c67bd20fa350ce211986451caa7feb5b60c8ff692e568073e007c34de7cb8847b8a1 SHA512 599147cd9aabc7c3bc24e6c82a13b690808899107999a3b0d7d3f2f113b38c90f2c720298ffdcdf1933d2573cced05d730dab53265397b7fc010e57feabc10b3
DIST dominate-2.3.4.tar.gz 27834 BLAKE2B 12eadd39e5088768c2cfc15e23093c53c58d90dab6346ac78d47da8b7d41fb50fabf4e186b9fea18ecb54fe8b6dae03a489b27a1942cfdc13437afe9e86919ef SHA512 6cab8d6d795498d70f28c80064407616e74e027ac112f8e097509482dce000e45c3599989430a17f71631616a860e84d842b2bfac39b4be466593b5cfb20123c
+DIST dominate-2.3.5.tar.gz 27875 BLAKE2B 72bac3554888427a3ed46f8e6a681ff8f48d37043fecc3ff984e65190bfd09bd28ab887168d7e56e0ce2fe8f7c986a4f9d4f47d2041524f53960a5ca3751826a SHA512 a48fff16fc3430201d757a5947c08397f821acdc07a2bd13bb77d65b0d71919726cf4f4792d591cf84ca05912223f439e9cb63e9d18b9a743b217e21ec97d3c2
diff --git a/dev-python/dominate/dominate-2.3.5.ebuild b/dev-python/dominate/dominate-2.3.5.ebuild
new file mode 100644
index 000000000000..078ac80b939c
--- /dev/null
+++ b/dev-python/dominate/dominate-2.3.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="https://github.com/Knio/dominate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}