summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/dockerpty
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/dockerpty')
-rw-r--r--dev-python/dockerpty/Manifest3
-rw-r--r--dev-python/dockerpty/dockerpty-0.3.2.ebuild47
-rw-r--r--dev-python/dockerpty/dockerpty-0.3.3.ebuild47
-rw-r--r--dev-python/dockerpty/dockerpty-0.3.4.ebuild47
-rw-r--r--dev-python/dockerpty/metadata.xml13
5 files changed, 157 insertions, 0 deletions
diff --git a/dev-python/dockerpty/Manifest b/dev-python/dockerpty/Manifest
new file mode 100644
index 000000000000..a456e3f830cb
--- /dev/null
+++ b/dev-python/dockerpty/Manifest
@@ -0,0 +1,3 @@
+DIST dockerpty-0.3.2.tar.gz 16808 SHA256 c937518704d5ced544a556f97efef57327690f1cd64d413767d79dadd062d85f SHA512 fccb52cfabe5bc8fe81e18179737a4aa9bb35d064d08b081dddd17805c47d8cc3aec23e49b3d0cc6b165fda158166965e56555a6ce8e633d5ba057d35e4061e4 WHIRLPOOL 0c0a1c0ce5e748f5771a776abfd3bb1300dc3d088ecec0620fa4ff6946ca9206297c770b57801380d2d160f358df91977ff977d3d3bfc9488958d53365939594
+DIST dockerpty-0.3.3.tar.gz 18583 SHA256 4b59a42c9b13c878439ccb2f75d017f88f306ab33fae7b20d8ac1f7e3fa72af7 SHA512 c5e0686c19b3ee3762c79d8f66602e25f3decd14c3ae35f514464c5e4c627e7653ca86f9e602535cb65c0d15d00ca5c687576214efe87a7309abca11cd6b8ea5 WHIRLPOOL 69bbf8bee0f52689e22827789fc05b64e6c09014e98a4075a746865567f8c790a533ce21f5e41319892b567fdbded6f428e0969a5b9c27b8726254d56901f6fa
+DIST dockerpty-0.3.4.tar.gz 18611 SHA256 d041b268264905818ca7cfc52e14b738c1ff2c21ef59ccbed5d5ef81d4a7591e SHA512 dee0cf8ae926bae3f5e96643e912d3cc2dbd782594fa148addac996909e7fec84e1e1579a8d00ce46479041e85496b0615cb4a68b635288d04a4ef73ad27b10d WHIRLPOOL ddd768c2b650301ac4c27fc9394d47f65303734abbbc1da7ddfdbd31ca89578a952b189e709a51134d0946985608af7ecb16108a52c8c6205b7ab58c0b7e7b61
diff --git a/dev-python/dockerpty/dockerpty-0.3.2.ebuild b/dev-python/dockerpty/dockerpty-0.3.2.ebuild
new file mode 100644
index 000000000000..8399d9dffebc
--- /dev/null
+++ b/dev-python/dockerpty/dockerpty-0.3.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python library to use the pseudo-tty of a docker container"
+HOMEPAGE="https://github.com/d11wtq/dockerpty"
+SRC_URI="https://github.com/d11wtq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/behave-1.2.4[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.5.2[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=">=dev-python/docker-py-0.3.2[${PYTHON_USEDEP}]"
+
+python_test() {
+ local RUN_FEATURES=0
+
+ ewarn "${PN} tests require portage to be in the docker group!"
+ getent group docker |& grep portage 1>/dev/null 2>&1
+ RUN_FEATURES+=$?
+
+ ewarn "${PN} tests require a running docker service!"
+ which docker 1>/dev/null 2>&1 && docker info 1>/dev/null 2>&1
+ RUN_FEATURES+=$?
+
+ if [[ ${RUN_FEATURES} -eq 0 ]]; then
+ behave || die "Feature tests failed under ${EPYTHON}"
+
+ fi
+
+ py.test tests || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/dockerpty/dockerpty-0.3.3.ebuild b/dev-python/dockerpty/dockerpty-0.3.3.ebuild
new file mode 100644
index 000000000000..1624bcb9cee0
--- /dev/null
+++ b/dev-python/dockerpty/dockerpty-0.3.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python library to use the pseudo-tty of a docker container"
+HOMEPAGE="https://github.com/d11wtq/dockerpty"
+SRC_URI="https://github.com/d11wtq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/behave-1.2.4[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.5.2[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=">=dev-python/six-1.3.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ local RUN_FEATURES=0
+
+ ewarn "${PN} tests require portage to be in the docker group!"
+ getent group docker |& grep portage 1>/dev/null 2>&1
+ RUN_FEATURES+=${?}
+
+ ewarn "${PN} tests require a running docker service!"
+ which docker 1>/dev/null 2>&1 && docker info 1>/dev/null 2>&1
+ RUN_FEATURES+=${?}
+
+ if [[ ${RUN_FEATURES} -eq 0 ]]; then
+ behave || die "Feature tests failed under ${EPYTHON}"
+
+ fi
+
+ py.test tests || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/dockerpty/dockerpty-0.3.4.ebuild b/dev-python/dockerpty/dockerpty-0.3.4.ebuild
new file mode 100644
index 000000000000..1624bcb9cee0
--- /dev/null
+++ b/dev-python/dockerpty/dockerpty-0.3.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python library to use the pseudo-tty of a docker container"
+HOMEPAGE="https://github.com/d11wtq/dockerpty"
+SRC_URI="https://github.com/d11wtq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/behave-1.2.4[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.5.2[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=">=dev-python/six-1.3.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ local RUN_FEATURES=0
+
+ ewarn "${PN} tests require portage to be in the docker group!"
+ getent group docker |& grep portage 1>/dev/null 2>&1
+ RUN_FEATURES+=${?}
+
+ ewarn "${PN} tests require a running docker service!"
+ which docker 1>/dev/null 2>&1 && docker info 1>/dev/null 2>&1
+ RUN_FEATURES+=${?}
+
+ if [[ ${RUN_FEATURES} -eq 0 ]]; then
+ behave || die "Feature tests failed under ${EPYTHON}"
+
+ fi
+
+ py.test tests || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/dockerpty/metadata.xml b/dev-python/dockerpty/metadata.xml
new file mode 100644
index 000000000000..5f64e0a5b6cb
--- /dev/null
+++ b/dev-python/dockerpty/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="github">d11wtq/dockerpty</remote-id>
+ </upstream>
+</pkgmetadata>