summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-tastypie
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-tastypie')
-rw-r--r--dev-python/django-tastypie/Manifest1
-rw-r--r--dev-python/django-tastypie/django-tastypie-0.9.15.ebuild61
-rw-r--r--dev-python/django-tastypie/files/runtests.patch46
-rw-r--r--dev-python/django-tastypie/metadata.xml18
4 files changed, 126 insertions, 0 deletions
diff --git a/dev-python/django-tastypie/Manifest b/dev-python/django-tastypie/Manifest
new file mode 100644
index 000000000000..447face09b83
--- /dev/null
+++ b/dev-python/django-tastypie/Manifest
@@ -0,0 +1 @@
+DIST django-tastypie-0.9.15.tar.gz 206823 SHA256 1509d8a93d4f0e16434469c5af850d3c1c625da902b54216771cc7b25634216a SHA512 dcb26f7bb131e658ff6a2d11ca8eb74db064986cd48e536fb4987a1cfe4c4958e99f60cf173b1bbbbc051f3e55bc31ff28e645a52f526b3a98461daddd865a74 WHIRLPOOL 62503c0f05e429950b2aacdbaeacfa2cc71eee24fad9e365373fda473b7bf54e3a251ec0b3133f128436922abc4ed8182f7405eb4a62e1a40628b2b44b596243
diff --git a/dev-python/django-tastypie/django-tastypie-0.9.15.ebuild b/dev-python/django-tastypie/django-tastypie-0.9.15.ebuild
new file mode 100644
index 000000000000..7488d57b958e
--- /dev/null
+++ b/dev-python/django-tastypie/django-tastypie-0.9.15.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test"
+
+DESCRIPTION="A flexible and capable API layer for django utilising serialisers"
+HOMEPAGE="http://pypi.python.org/pypi/django-tastypie/ https://github.com/toastdriven/django-tastypie"
+SRC_URI="https://github.com/toastdriven/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE="bip doc digest lxml test yaml"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=">=dev-python/mimeparse-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ >=dev-python/django-1.3[${PYTHON_USEDEP}]
+ dev-python/pyxml[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ bip? ( dev-python/biplist[${PYTHON_USEDEP}] )
+ digest? ( dev-python/python-digest[${PYTHON_USEDEP}] )
+ lxml? ( dev-python/lxml[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/oauth2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-digest[${PYTHON_USEDEP}]
+ dev-python/biplist[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/mimeparse-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/runtests.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+src_test() {
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+python_test() {
+ PYTHONPATH=.:tests ./tests/run_all_tests.sh || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-tastypie/files/runtests.patch b/dev-python/django-tastypie/files/runtests.patch
new file mode 100644
index 000000000000..473d3338101a
--- /dev/null
+++ b/dev-python/django-tastypie/files/runtests.patch
@@ -0,0 +1,46 @@
+The run tests bash script keeps going on a fail. Patch corrects this for gentoo
+diff -ur django-tastypie-0.9.15.oirg/tests/run_all_tests.sh django-tastypie-0.9.15/tests/run_all_tests.sh
+--- tests/run_all_tests.sh 2013-05-03 10:36:43.000000000 +0800
++++ tests/run_all_tests.sh 2013-06-03 13:55:18.633474126 +0800
+@@ -10,9 +10,9 @@
+
+ #Don't run customuser tests if django's version is less than 1.5.
+ if [ $major -lt '2' -a $minor -lt '5' ]; then
+- ALL="core basic alphanumeric slashless namespaced related validation gis content_gfk authorization"
++ ALL="core basic alphanumeric slashless namespaced related validation content_gfk authorization"
+ else
+- ALL="core customuser basic alphanumeric slashless namespaced related validation gis content_gfk authorization"
++ ALL="core customuser basic alphanumeric slashless namespaced related validation content_gfk authorization"
+ fi
+
+
+@@ -26,15 +26,23 @@
+ fi
+
+ for type in $TYPES; do
+- echo "** $type **"
++ echo "** running test $type **"
+
+ if [ $type == 'related' ]; then
+- django-admin.py test ${type}_resource --settings=settings_$type
+- continue
++ if django-admin.py test ${type}_resource --settings=settings_$type; then
++ continue
++ else
++ echo "Test ${type} failed"
++ exit 1
++ fi
+ elif [ $type == 'gis' ]; then
+- createdb -T template_postgis tastypie.db
++ createdb -T template_posttastypie.db
+ fi
+
+- django-admin.py test $type --settings=settings_$type
+- echo; echo
++ if ! django-admin.py test $type --settings=settings_$type; then
++ echo "Test ${type} failed"
++ exit 1
++ else
++ echo; echo
++ fi
+ done
diff --git a/dev-python/django-tastypie/metadata.xml b/dev-python/django-tastypie/metadata.xml
new file mode 100644
index 000000000000..1d47d2cae77c
--- /dev/null
+++ b/dev-python/django-tastypie/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <herd>python</herd>
+ <use>
+ <flag name="bip">An optional serialiser dev-python/biplist</flag>
+ <flag name="digest">Library to aid in implementing HTTP Digest Authentication</flag>
+ <flag name="lxml">An optional serialiser dev-python/lxml</flag>
+ <flag name="yaml">An optional serialiser dev-python/yaml</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">toastdriven/django-tastypie</remote-id>
+ </upstream>
+</pkgmetadata>