summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-formtools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-formtools')
-rw-r--r--dev-python/django-formtools/Manifest1
-rw-r--r--dev-python/django-formtools/django-formtools-1.0.ebuild30
-rw-r--r--dev-python/django-formtools/metadata.xml12
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-formtools/Manifest b/dev-python/django-formtools/Manifest
new file mode 100644
index 000000000000..407ab6f39128
--- /dev/null
+++ b/dev-python/django-formtools/Manifest
@@ -0,0 +1 @@
+DIST django-formtools-1.0.tar.gz 70505 SHA256 647a5855277dcf335902eeeeeba3056e439493e6b7de70b942c988a6d8d70e04 SHA512 828ea5f5057d7ec72ab6cc6613e8af950f16595115bba658892e15aec39498f6e7c3dcb5c50ac4fc7ef54e12a640ed93e76a968f41bec59388630cdc43c9e3ce WHIRLPOOL ef8371e2e41b52b7c58fae2a5c58eef63354fddeeeaa2eb7808df45d003998a955842cf395cb07ce8cb7ea003b01f16b5834c2441ebf8548cd5e21d4ee0f2797
diff --git a/dev-python/django-formtools/django-formtools-1.0.ebuild b/dev-python/django-formtools/django-formtools-1.0.ebuild
new file mode 100644
index 000000000000..e1d5681a338a
--- /dev/null
+++ b/dev-python/django-formtools/django-formtools-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="High-level abstractions for Django forms"
+HOMEPAGE="http://django-formtools.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="!<dev-python/django-1.8"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/django-1.8[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ emake test
+}
diff --git a/dev-python/django-formtools/metadata.xml b/dev-python/django-formtools/metadata.xml
new file mode 100644
index 000000000000..c2893eed6c67
--- /dev/null
+++ b/dev-python/django-formtools/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-formtools</remote-id>
+ </upstream>
+</pkgmetadata>