summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-03 08:43:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-03 08:43:13 +0200
commit0f180297460aae8e4dfd53c5714be7543aecf454 (patch)
tree3079d88f473416611d4105f2d796fbd5c06bc236 /dev-python/django-configurations
parentdev-python/virtualenv: Remove old (diff)
downloadgentoo-0f180297460aae8e4dfd53c5714be7543aecf454.tar.gz
gentoo-0f180297460aae8e4dfd53c5714be7543aecf454.tar.bz2
gentoo-0f180297460aae8e4dfd53c5714be7543aecf454.zip
dev-python/django-configurations: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-configurations')
-rw-r--r--dev-python/django-configurations/Manifest1
-rw-r--r--dev-python/django-configurations/django-configurations-2.3.2.ebuild51
-rw-r--r--dev-python/django-configurations/files/django-configurations-2.3.2-test.patch45
3 files changed, 0 insertions, 97 deletions
diff --git a/dev-python/django-configurations/Manifest b/dev-python/django-configurations/Manifest
index 1fee3c094acf..290a53ddecff 100644
--- a/dev-python/django-configurations/Manifest
+++ b/dev-python/django-configurations/Manifest
@@ -1,2 +1 @@
-DIST django-configurations-2.3.2.gh.tar.gz 38475 BLAKE2B 2b3c583e665a08a46bc0ca0c52ae4326fbdfb794d102deecbd13f953e8b6f3fd39b3b747c591fc9717c6a0792258cdb9041de53e71db2034de1a31ddf5bfc0ea SHA512 4cb5a7b284a0025ba93b32e158fb65b57e66230938181b921a1b1264848113b697eb45ac6ad2fc4f26f3bc29ea5f77acbfd5307b20ef2d385e29c2c1746295b3
DIST django-configurations-2.4.gh.tar.gz 38563 BLAKE2B a454cc492354c1b969a1b0389ccb21088e99af17b5056ae514b36b5c2fd7391368437093d1a075814dfb8e15ec8ce3ec3c5269d5c867b4a03a5269a533826a31 SHA512 de9793c5fce869ef77e4396dd5ea45fc57728d702383885599d3a08b16e37e0e425258aacd671ac78592df813c8fa3a08b33ad9410843f7d7976589da33592ca
diff --git a/dev-python/django-configurations/django-configurations-2.3.2.ebuild b/dev-python/django-configurations/django-configurations-2.3.2.ebuild
deleted file mode 100644
index 65cfca8e9dc9..000000000000
--- a/dev-python/django-configurations/django-configurations-2.3.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A helper for organizing Django settings"
-HOMEPAGE="
- https://pypi.org/project/django-configurations/
- https://github.com/jazzband/django-configurations/
- https://django-configurations.readthedocs.io/
-"
-SRC_URI="
- https://github.com/jazzband/django-configurations/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/django[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/django-cache-url[${PYTHON_USEDEP}]
- dev-python/dj-database-url[${PYTHON_USEDEP}]
- dev-python/dj-email-url[${PYTHON_USEDEP}]
- dev-python/dj-search-url[${PYTHON_USEDEP}]
- )
-"
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-PATCHES=(
- "${FILESDIR}"/${P}-test.patch
-)
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=tests.settings.main
- local -x DJANGO_CONFIGURATION=Test
- PYTHONPATH=. django-cadmin test -v2 || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/django-configurations/files/django-configurations-2.3.2-test.patch b/dev-python/django-configurations/files/django-configurations-2.3.2-test.patch
deleted file mode 100644
index 19787102920a..000000000000
--- a/dev-python/django-configurations/files/django-configurations-2.3.2-test.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/tests/test_values.py b/tests/test_values.py
-index 2547e50..2f1170b 100644
---- a/tests/test_values.py
-+++ b/tests/test_values.py
-@@ -2,6 +2,7 @@ import decimal
- import os
- from contextlib import contextmanager
-
-+from django import VERSION as DJANGO_VERSION
- from django.test import TestCase
- from django.core.exceptions import ImproperlyConfigured
-
-@@ -411,6 +412,7 @@ class ValueTests(TestCase):
- 'EMAIL_HOST_PASSWORD': 'password',
- 'EMAIL_HOST_USER': 'user@domain.com',
- 'EMAIL_PORT': 587,
-+ 'EMAIL_TIMEOUT': None,
- 'EMAIL_USE_SSL': False,
- 'EMAIL_USE_TLS': True})
- with env(EMAIL_URL='console://'):
-@@ -421,6 +423,7 @@ class ValueTests(TestCase):
- 'EMAIL_HOST_PASSWORD': None,
- 'EMAIL_HOST_USER': None,
- 'EMAIL_PORT': None,
-+ 'EMAIL_TIMEOUT': None,
- 'EMAIL_USE_SSL': False,
- 'EMAIL_USE_TLS': False})
- with env(EMAIL_URL='smtps://user@domain.com:password@smtp.example.com:wrong'): # noqa: E501
-@@ -429,7 +432,7 @@ class ValueTests(TestCase):
- def test_cache_url_value(self):
- cache_setting = {
- 'default': {
-- 'BACKEND': 'django_redis.cache.RedisCache',
-+ 'BACKEND': 'django_redis.cache.RedisCache' if DJANGO_VERSION[0] < 4 else 'django.core.cache.backends.redis.RedisCache',
- 'LOCATION': 'redis://host:6379/1',
- }
- }
-@@ -503,6 +506,7 @@ class ValueTests(TestCase):
- 'EMAIL_HOST_PASSWORD': 'password',
- 'EMAIL_HOST_USER': 'user@domain.com',
- 'EMAIL_PORT': 587,
-+ 'EMAIL_TIMEOUT': None,
- 'EMAIL_USE_SSL': False,
- 'EMAIL_USE_TLS': True
- })