summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-14 21:26:28 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-14 21:26:28 +0300
commitfccd894c0d140dfbf8329d5d8e2f1ef64cd7ea4e (patch)
treeae99803da4613acbc61c691215d5014db92814dc /dev-python/distlib
parentdev-python/distlib: add 0.3.5 (diff)
downloadgentoo-fccd894c0d140dfbf8329d5d8e2f1ef64cd7ea4e.tar.gz
gentoo-fccd894c0d140dfbf8329d5d8e2f1ef64cd7ea4e.tar.bz2
gentoo-fccd894c0d140dfbf8329d5d8e2f1ef64cd7ea4e.zip
dev-python/distlib: drop 0.3.4-r1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/distlib-0.3.4-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/distlib/distlib-0.3.4-r1.ebuild b/dev-python/distlib/distlib-0.3.4-r1.ebuild
deleted file mode 100644
index 4dc1127a1909..000000000000
--- a/dev-python/distlib/distlib-0.3.4-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Low-level components of distutils2/packaging"
-HOMEPAGE="https://pypi.org/project/distlib/
- https://bitbucket.org/pypa/distlib/"
-# pypi has zip only :-(
-SRC_URI="
- https://bitbucket.org/pypa/distlib/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-# This package's tests are extremely fragile and tend to break or hang
-# when it doesn't like metadata of packages installed on the system.
-RESTRICT="test"
-
-# pypiserver is called as external executable
-# openpyxl installs invalid metadata that breaks distlib
-BDEPEND="
- test? (
- dev-python/pypiserver
- !!<dev-python/openpyxl-3.0.3[${PYTHON_USEDEP}]
- )"
-
-src_prepare() {
- # make sure they're not used
- rm tests/pypi-server-standalone.py || die
-
- # use system pypiserver instead of broken bundled one
- eapply "${FILESDIR}"/distlib-0.3.2-system-pypiserver.py || die
-
- # doesn't work with our patched pip
- sed -e '/PIP_AVAIL/s:True:False:' \
- -i tests/test_wheel.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x SKIP_ONLINE=1
- local -x PYTHONHASHSEED=0
- "${EPYTHON}" tests/test_all.py -v -x ||
- die "Tests failed with ${EPYTHON}"
-}