summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-28 10:29:23 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-28 14:34:28 +0100
commit36591fe050f9a043b56ef0546de18585d43db015 (patch)
treeebb69ca4dcffe87cbe62d8ef79179181efb3a572 /dev-python/distlib/distlib-0.2.1-r1.ebuild
parentMerge remote-tracking branch 'remotes/Coacher/mpv-refactor-take-2' (diff)
downloadgentoo-36591fe050f9a043b56ef0546de18585d43db015.tar.gz
gentoo-36591fe050f9a043b56ef0546de18585d43db015.tar.bz2
gentoo-36591fe050f9a043b56ef0546de18585d43db015.zip
dev-python/distlib: Fix varios test failures
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=558706 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=558708 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=569922 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/distlib/distlib-0.2.1-r1.ebuild')
-rw-r--r--dev-python/distlib/distlib-0.2.1-r1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/distlib/distlib-0.2.1-r1.ebuild b/dev-python/distlib/distlib-0.2.1-r1.ebuild
index 1a438d68273d..8b8f7c9ecc86 100644
--- a/dev-python/distlib/distlib-0.2.1-r1.ebuild
+++ b/dev-python/distlib/distlib-0.2.1-r1.ebuild
@@ -20,6 +20,7 @@ IUSE=""
PATCHES=(
"${FILESDIR}"/${P}-unbundle.patch
+ "${FILESDIR}"/${P}-online.patch
)
python_prepare_all() {
@@ -29,20 +30,24 @@ python_prepare_all() {
tests/test_shutil.py* \
tests/test_sysconfig.py* || die
+ distutils-r1_python_prepare_all
+
# Broken tests
# 1 fails due to it being sensitive to dictionary ordering
# inconsistency between code and test
sed \
-e 's:test_dependency_finder:_&:g' \
- -e 's:test_abi:_&:g' \
-i tests/*py || die
- distutils-r1_python_prepare_all
+ # Gentoo still doesn't report correct ABI
+ sed \
+ -e 's:test_abi:_&:g' \
+ -i tests/*py || die
}
python_test() {
sed \
-e '/PIP_AVAILABLE/s:True:False:g' \
-i tests/*py || die
- PYTHONHASHSEED=0 esetup.py test
+ SKIP_ONLINE=True PYTHONHASHSEED=0 esetup.py test
}