summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-24 00:29:51 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-24 00:44:32 +0200
commit27c3aaec24b9f604673bf84e6cafb7d50d0de8fa (patch)
tree895ec387bb4e60728b57f6fd4b40c2ce96e770b6 /dev-python/dicttoxml
parentdev-python/moto: remove unused dicttoxml dependency (diff)
downloadgentoo-27c3aaec24b9f604673bf84e6cafb7d50d0de8fa.tar.gz
gentoo-27c3aaec24b9f604673bf84e6cafb7d50d0de8fa.tar.bz2
gentoo-27c3aaec24b9f604673bf84e6cafb7d50d0de8fa.zip
dev-python/dicttoxml: enable py3.10
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/dicttoxml')
-rw-r--r--dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild22
-rw-r--r--dev-python/dicttoxml/files/dicttoxml-1.7.4-py3.10.patch58
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild b/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild
new file mode 100644
index 000000000000..a6882bd19034
--- /dev/null
+++ b/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Converts a Python dictionary or other data type to a valid XML string"
+HOMEPAGE="https://github.com/quandyfactory/dicttoxml https://pypi.org/project/dicttoxml/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+PATCHES=(
+ # https://github.com/quandyfactory/dicttoxml/pull/73/files
+ "${FILESDIR}/${P}-py3.10.patch"
+)
diff --git a/dev-python/dicttoxml/files/dicttoxml-1.7.4-py3.10.patch b/dev-python/dicttoxml/files/dicttoxml-1.7.4-py3.10.patch
new file mode 100644
index 000000000000..5b3fe172949e
--- /dev/null
+++ b/dev-python/dicttoxml/files/dicttoxml-1.7.4-py3.10.patch
@@ -0,0 +1,58 @@
+From 2b7b4522b7255fbc8f1e04304d2e440d333909d5 Mon Sep 17 00:00:00 2001
+From: Kier von Konigslow <kvonkonigslow@gmail.com>
+Date: Sat, 28 Dec 2019 14:08:46 -0500
+Subject: [PATCH] Fix deprecation with collections abc
+
+---
+ dicttoxml.py | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/dicttoxml.py b/dicttoxml.py
+index ae1384a..5d2dd54 100755
+--- a/dicttoxml.py
++++ b/dicttoxml.py
+@@ -15,7 +15,7 @@
+ version = __version__
+
+ from random import randint
+-import collections
++import collections.abc
+ import numbers
+ import logging
+ from xml.dom.minidom import parseString
+@@ -96,7 +96,7 @@ def get_xml_type(val):
+ return 'null'
+ if isinstance(val, dict):
+ return 'dict'
+- if isinstance(val, collections.Iterable):
++ if isinstance(val, collections.abc.Iterable):
+ return 'list'
+ return type(val).__name__
+
+@@ -188,7 +188,7 @@ def convert(obj, ids, attr_type, item_func, cdata, parent='root'):
+ if isinstance(obj, dict):
+ return convert_dict(obj, ids, parent, attr_type, item_func, cdata)
+
+- if isinstance(obj, collections.Iterable):
++ if isinstance(obj, collections.abc.Iterable):
+ return convert_list(obj, ids, parent, attr_type, item_func, cdata)
+
+ raise TypeError('Unsupported data type: %s (%s)' % (obj, type(obj).__name__))
+@@ -232,7 +232,7 @@ def convert_dict(obj, ids, parent, attr_type, item_func, cdata):
+ )
+ )
+
+- elif isinstance(val, collections.Iterable):
++ elif isinstance(val, collections.abc.Iterable):
+ if attr_type:
+ attr['type'] = get_xml_type(val)
+ addline('<%s%s>%s</%s>' % (
+@@ -295,7 +295,7 @@ def convert_list(items, ids, parent, attr_type, item_func, cdata):
+ )
+ )
+
+- elif isinstance(item, collections.Iterable):
++ elif isinstance(item, collections.abc.Iterable):
+ if not attr_type:
+ addline('<%s %s>%s</%s>' % (
+ item_name, make_attrstring(attr),