summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-11-10 09:25:28 +0200
committerMichał Górny <mgorny@gentoo.org>2019-11-29 20:54:32 +0100
commit5507a80bd8dd0ae99ef076787fc04449c0395ba5 (patch)
treeb322c0320d335276b80d876ff525f350af192b52 /dev-python/decorator
parentdev-python/lazy-object-proxy: Fix MissingTestRestrict (diff)
downloadgentoo-5507a80bd8dd0ae99ef076787fc04449c0395ba5.tar.gz
gentoo-5507a80bd8dd0ae99ef076787fc04449c0395ba5.tar.bz2
gentoo-5507a80bd8dd0ae99ef076787fc04449c0395ba5.zip
dev-python/decorator: bump v4.4.1
move dev-python/setuptools to BDEPEND use distutils_enable_tests for tests Closes: https://bugs.gentoo.org/683106 Closes: https://bugs.gentoo.org/683076 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/decorator')
-rw-r--r--dev-python/decorator/Manifest1
-rw-r--r--dev-python/decorator/decorator-4.4.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/decorator/Manifest b/dev-python/decorator/Manifest
index 25316611308f..8fc496b21d58 100644
--- a/dev-python/decorator/Manifest
+++ b/dev-python/decorator/Manifest
@@ -1,2 +1,3 @@
DIST decorator-4.3.2.tar.gz 34892 BLAKE2B 49485ec0ae25947b27dbc23c8f17194bf5b03778e7e43524e561c320487e1b6830a1ab39e9fba2a154e1cd00155af779965e497724f01d81d301a0ca979ba058 SHA512 87102e1b314086d008c48bf53f1061b28fdbd3ccd3d301773102fd43e3a4ce8b5ffeb9107fb5d5f47b7bd45c26e5b3b2913ea20745ffc9b274e2c0b24a69ef70
DIST decorator-4.4.0.tar.gz 34559 BLAKE2B ed8cad0081ca47cef15f30d10afda1d19dd496f482a4621a1a349d0b5fa63d41ea4daee389d21b8b176be09949f8519c117a448003b2e8ee5f5c2d50d3015cac SHA512 32c35c80581cb7fd0b2461d21c7eb14190294b2ccc9f92749b6bc74449f7d02a26281e9a2817f6f16871a6cddb7b02b8fae8119c22256fe43a6aaa31a7599dd5
+DIST decorator-4.4.1.tar.gz 33350 BLAKE2B 75544aeb6dd995edc091515da70f4bfff8a12a02442b47c945d4ab18e90eb48647cdc86540de542ff3357cb2114eebdefead7edeeba25587a15fb1e7c87519c6 SHA512 12378702246b212d5fe0153dc97cafdb2afd4779c51fd224385e3c3562e1a1e3439574aa7c37c8521fe5f86a5f0b4d4b3075e0407cc249f8fa4b341e1ebe06e0
diff --git a/dev-python/decorator/decorator-4.4.1.ebuild b/dev-python/decorator/decorator-4.4.1.ebuild
new file mode 100644
index 000000000000..c7eead64caa6
--- /dev/null
+++ b/dev-python/decorator/decorator-4.4.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplifies the usage of decorators for the average programmer"
+HOMEPAGE="https://github.com/micheles/decorator https://pypi.org/project/decorator/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( CHANGES.md )
+
+distutils_enable_tests setup.py