summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-11 10:44:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-11 10:50:17 +0200
commit679de3b0db79a7b579baf5e5386f1ed0108d207e (patch)
treed60e24aa2af5c120ad2ab50dfcf5e42c995f5dee /dev-python/ddt
parentdev-python/proto-plus: Bump to 1.22.0 (diff)
downloadgentoo-679de3b0db79a7b579baf5e5386f1ed0108d207e.tar.gz
gentoo-679de3b0db79a7b579baf5e5386f1ed0108d207e.tar.bz2
gentoo-679de3b0db79a7b579baf5e5386f1ed0108d207e.zip
dev-python/ddt: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ddt')
-rw-r--r--dev-python/ddt/Manifest1
-rw-r--r--dev-python/ddt/ddt-1.6.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/ddt/Manifest b/dev-python/ddt/Manifest
index 10f6e392a1f8..c28180c713c4 100644
--- a/dev-python/ddt/Manifest
+++ b/dev-python/ddt/Manifest
@@ -1 +1,2 @@
DIST ddt-1.5.0.tar.gz 19609 BLAKE2B 8986a7e3df8212dbd5ec6fd15e5cc73c5da65db56cf9234acd83649fc5fb988eccb9605a7fa09188ff9499e759c84ff076d86fbba2e3eeda054224acc8382626 SHA512 91faba2bed66df5cf366011343886e3f0059d4e0f44ca46ffcfed7288068ba43a94a426bd692717b3ea735437ee6c0339d42b5c15f75221386153c035597ae5c
+DIST ddt-1.6.0.gh.tar.gz 19615 BLAKE2B f79e25e9da39615d85f000c1029babef64725b159a2b77003efe9f9c5869fb26087fa20e1a58eea485479b12ee89c602076613a9d50711347a775a09c4bbb180 SHA512 c5ea14d3f60384676d9631c84d938b774dd360cea9b0ee1b111692dc2bc06238b5ffd3ab8950207b77aa007bac0ac79b290533a2532be4bee68b642629843a82
diff --git a/dev-python/ddt/ddt-1.6.0.ebuild b/dev-python/ddt/ddt-1.6.0.ebuild
new file mode 100644
index 000000000000..01c20fb5b0e5
--- /dev/null
+++ b/dev-python/ddt/ddt-1.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Data-Driven/Decorated Tests"
+HOMEPAGE="
+ https://pypi.org/project/ddt/
+ https://github.com/datadriventests/ddt/
+"
+SRC_URI="
+ https://github.com/datadriventests/ddt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest