summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-02 23:49:59 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-03 10:11:20 +0100
commit648a474f90e8f7983ac6107cfba52aef20d62d3c (patch)
tree0d3313132d792530f61b9bf5b89eb1882316d6c5 /dev-python/cython
parentdev-python/cryptography-vectors: Clean old up (diff)
downloadgentoo-648a474f90e8f7983ac6107cfba52aef20d62d3c.tar.gz
gentoo-648a474f90e8f7983ac6107cfba52aef20d62d3c.tar.bz2
gentoo-648a474f90e8f7983ac6107cfba52aef20d62d3c.zip
dev-python/cython: Clean old up
Diffstat (limited to 'dev-python/cython')
-rw-r--r--dev-python/cython/Manifest3
-rw-r--r--dev-python/cython/cython-0.22.ebuild62
-rw-r--r--dev-python/cython/cython-0.24.1.ebuild80
-rw-r--r--dev-python/cython/cython-0.26.ebuild80
4 files changed, 0 insertions, 225 deletions
diff --git a/dev-python/cython/Manifest b/dev-python/cython/Manifest
index 98b55c14e494..7bdb79ba8833 100644
--- a/dev-python/cython/Manifest
+++ b/dev-python/cython/Manifest
@@ -1,5 +1,2 @@
-DIST Cython-0.22.tar.gz 1584483 BLAKE2B a221a922c6e22450499269c8756063a22259f21b8b422e72aede6fa80e6154ab36b4f94e54e246756d89b86c1f730d47ad2c7350ecfa61b26f57f4e40988895e SHA512 856220fa579e272ac38dcef091760f527431ff3b98df9af6e68416fcf77d9659ac5abe5c7dee41331f359614637a4ff452033085335ee499830ed126ab584267
-DIST Cython-0.24.1.tar.gz 1703756 BLAKE2B 92b1646d874adfd0a56cf9464f93e6215ee3be72693c814e2748abd6113362370e84af20941e92e10cac4311c4af822f899d8659975d5d9e398f969c1f746a3f SHA512 c5a3e884edd782c47c81aef29708035bbcd1c14d17e005668da8a4e26fdbba9af9ec283fd46ceaa2cab6fc4ec0d42f7d409832d7cc0a3ec00e84b968b1bf27ea
DIST Cython-0.25.2.tar.gz 1703315 BLAKE2B e458604d0843afa128c6019244220bd6b3dd6653013698aa67ee2f71555f09813a8136ef92d6dc51ca38fe085e7bedc5e01d1a32bbd0885e62bd91c2e482bebd SHA512 1974b9374aeedb030307dc95aa6560ce9d5e1652783cd4552e96ef11663c73dd263e3521b68e7712abbb31628011e2e66320c5ee2577968684e2679eb80726e1
DIST Cython-0.26.1.tar.gz 1725133 BLAKE2B b2c0433e8154ad76d921677608cae42a793326015ff320d8cd61818e5eb5fb4daf73ad4e72760d84f4cdaa2386b87d719cf9cd41584b781d4e2021e377a58422 SHA512 cdf31afaba78209c37a224345471c5c822b78c6d26c51583c46669b6b2b57b4952b33a839a51d06c3330fdff889345ac611fbaa2b2f17498cb02f3b5675f7948
-DIST Cython-0.26.tar.gz 1692039 BLAKE2B ff1c6366dd224de31de373b341add34dfc2e3d9ef01ecf438b03aa96e7fca144ba4b68b90589f2ebf7bb6cd61f1e0166019bfac4a7b240950a6ba8a4bd626af8 SHA512 58b7dbdca3b1bdfcb8b968cb1b59826b793656bb7f1203a80b59b3fae2d3174cc99f19f88fc2ec175aa98c9daeca0eb3c52674a7889ba1e914fd20d19ef92aed
diff --git a/dev-python/cython/cython-0.22.ebuild b/dev-python/cython/cython-0.22.ebuild
deleted file mode 100644
index ad25b03c6954..000000000000
--- a/dev-python/cython/cython-0.22.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic toolchain-funcs
-
-MY_PN="Cython"
-MY_P="${MY_PN}-${PV/_/}"
-
-DESCRIPTION="A Python to C compiler"
-HOMEPAGE="http://www.cython.org/ https://pypi.python.org/pypi/Cython"
-SRC_URI="http://www.cython.org/release/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-
-RDEPEND=""
-# On testing, setuptools invokes an error in running the testsuite cited in a number of recent bugs
-# spanning several packages. This bug has been fixed in the recent release of version 9.1
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-9.1[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_PN}-${PV%_*}"
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS}"
- local CXXFLAGS="${CXXFLAGS}"
- append-flags -fno-strict-aliasing
- fi
-
- # Python gets confused when it is in sys.path before build.
- local PYTHONPATH=
- export PYTHONPATH
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && unset XDG_CONFIG_HOME && emake -C docs html
-}
-
-python_test() {
- tc-export CC
- "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES.rst README.txt ToDo.txt USAGE.txt )
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && local EXAMPLES=( Demos/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/cython/cython-0.24.1.ebuild b/dev-python/cython/cython-0.24.1.ebuild
deleted file mode 100644
index 1b46d1f93fd8..000000000000
--- a/dev-python/cython/cython-0.24.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic toolchain-funcs elisp-common
-
-MY_PN="Cython"
-MY_P="${MY_PN}-${PV/_/}"
-
-DESCRIPTION="A Python to C compiler"
-HOMEPAGE="http://cython.org https://pypi.python.org/pypi/Cython"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-
-IUSE="doc emacs test"
-
-RDEPEND="
- emacs? ( virtual/emacs )
-"
-# On testing, setuptools invokes an error in running the testsuite cited in a number of recent bugs
-# spanning several packages. This bug has been fixed in the recent release of version 9.1
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-9.1[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
-
-SITEFILE=50cython-gentoo.el
-S="${WORKDIR}/${MY_PN}-${PV%_*}"
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS}"
- local CXXFLAGS="${CXXFLAGS}"
- append-flags -fno-strict-aliasing
- fi
-
- # Python gets confused when it is in sys.path before build.
- local PYTHONPATH=
- export PYTHONPATH
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use emacs && elisp-compile Tools/cython-mode.el
-
- use doc && unset XDG_CONFIG_HOME && emake -C docs html
-}
-
-python_test() {
- tc-export CC
- "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES.rst README.txt ToDo.txt USAGE.txt )
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-
- if use emacs; then
- elisp-install ${PN} Tools/cython-mode.*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-python/cython/cython-0.26.ebuild b/dev-python/cython/cython-0.26.ebuild
deleted file mode 100644
index 7599fb5e7e1f..000000000000
--- a/dev-python/cython/cython-0.26.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic toolchain-funcs elisp-common
-
-MY_PN="Cython"
-MY_P="${MY_PN}-${PV/_/}"
-
-DESCRIPTION="A Python to C compiler"
-HOMEPAGE="http://cython.org https://pypi.python.org/pypi/Cython"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-
-IUSE="doc emacs test"
-
-RDEPEND="
- emacs? ( virtual/emacs )
-"
-# On testing, setuptools invokes an error in running the testsuite cited in a number of recent bugs
-# spanning several packages. This bug has been fixed in the recent release of version 9.1
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-9.1[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
-
-SITEFILE=50cython-gentoo.el
-S="${WORKDIR}/${MY_PN}-${PV%_*}"
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS}"
- local CXXFLAGS="${CXXFLAGS}"
- append-flags -fno-strict-aliasing
- fi
-
- # Python gets confused when it is in sys.path before build.
- local PYTHONPATH=
- export PYTHONPATH
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use emacs && elisp-compile Tools/cython-mode.el
-
- use doc && unset XDG_CONFIG_HOME && emake -C docs html
-}
-
-python_test() {
- tc-export CC
- "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES.rst README.txt ToDo.txt USAGE.txt )
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-
- if use emacs; then
- elisp-install ${PN} Tools/cython-mode.*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}