summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-01-09 13:03:32 -0500
committerMike Gilbert <floppym@gentoo.org>2020-01-09 13:04:14 -0500
commit484ac3d510a71d0c47a2841d06dd79cb5a34b202 (patch)
tree2031bc4409614d0f55b5cf0832b05be9b46c8427 /dev-python/cryptography
parentkde-apps: Add KDE Applications 19.12.1 (diff)
downloadgentoo-484ac3d510a71d0c47a2841d06dd79cb5a34b202.tar.gz
gentoo-484ac3d510a71d0c47a2841d06dd79cb5a34b202.tar.bz2
gentoo-484ac3d510a71d0c47a2841d06dd79cb5a34b202.zip
dev-python/cryptography: add cffi to RDEPEND
cryptography installs egg-info/requires.txt containing cffi. This means packages using pkg_resources to import cryptography will fail if cffi is not installed at runtime. Closes: https://bugs.gentoo.org/696224 Package-Manager: Portage-2.3.84_p2, Repoman-2.3.20_p24 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python/cryptography')
-rw-r--r--dev-python/cryptography/cryptography-2.6.1-r1.ebuild (renamed from dev-python/cryptography/cryptography-2.6.1.ebuild)4
-rw-r--r--dev-python/cryptography/cryptography-2.8-r1.ebuild (renamed from dev-python/cryptography/cryptography-2.8.ebuild)4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/cryptography/cryptography-2.6.1.ebuild b/dev-python/cryptography/cryptography-2.6.1-r1.ebuild
index 5eb0f608b495..d0c85a6a8fd1 100644
--- a/dev-python/cryptography/cryptography-2.6.1.ebuild
+++ b/dev-python/cryptography/cryptography-2.6.1-r1.ebuild
@@ -39,11 +39,11 @@ RDEPEND="
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
virtual/python-enum34[${PYTHON_USEDEP}]
virtual/python-ipaddress[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
test? (
~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
dev-python/pretend[${PYTHON_USEDEP}]
diff --git a/dev-python/cryptography/cryptography-2.8.ebuild b/dev-python/cryptography/cryptography-2.8-r1.ebuild
index edd5696da250..a3a34f92d7fc 100644
--- a/dev-python/cryptography/cryptography-2.8.ebuild
+++ b/dev-python/cryptography/cryptography-2.8-r1.ebuild
@@ -40,11 +40,11 @@ RDEPEND="
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
virtual/python-enum34[${PYTHON_USEDEP}]
virtual/python-ipaddress[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
test? (
dev-python/pretend[${PYTHON_USEDEP}]
dev-python/iso8601[${PYTHON_USEDEP}]