summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 17:32:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 18:04:00 +0100
commit5bbec821fceda13240cc91cf5f516ac152d9b34c (patch)
tree2e2ef15c157a5d4ee2d6dad088ff8f3bb0ad53b7 /dev-python/construct
parentwww-apps/hugo: Remove old ebuild (diff)
downloadgentoo-5bbec821fceda13240cc91cf5f516ac152d9b34c.tar.gz
gentoo-5bbec821fceda13240cc91cf5f516ac152d9b34c.tar.bz2
gentoo-5bbec821fceda13240cc91cf5f516ac152d9b34c.zip
dev-python/construct: Bump to 2.10.68
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/construct')
-rw-r--r--dev-python/construct/Manifest1
-rw-r--r--dev-python/construct/construct-2.10.68.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index 1bcd312a9e96..56890aaefcb7 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -1 +1,2 @@
DIST construct-2.10.67.tar.gz 1189939 BLAKE2B e3effd2bb2906435208ef6a5fadbdbde2e1ef3565174568949207bdace48e25f423932f08598c82df661919d926a18d49767ea1189b01a5a3ee48aae601c45c8 SHA512 a4c7cc32b9eb63311c6ae2b1580b7a696c1e0c3960d78936798dd794cb37a77ec8ed8baa8128f12abd50390b9f4cb3f150e3453d5043797f0bd603525b8292a5
+DIST construct-2.10.68.tar.gz 1190512 BLAKE2B b41e5b3b62cd1568c78ac4975b0d66e7a7ad4489e97031d3e866ff8eb98eea4eb387041dce15210304c608e0c419548cddea3557c2f53d52ecbcf6eb5be67749 SHA512 2388751323b16b69a06457c4862e7d1334580c201050734f150ab4437e2066ed18ff5323f7d81b8bb93124ae0f57a2ae91d7c64ffefc6e0369d6e625b7fef4eb
diff --git a/dev-python/construct/construct-2.10.68.ebuild b/dev-python/construct/construct-2.10.68.ebuild
new file mode 100644
index 000000000000..b97a308445b2
--- /dev/null
+++ b/dev-python/construct/construct-2.10.68.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="https://construct.readthedocs.io/en/latest/ https://pypi.org/project/construct/"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/lz4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.4[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_benchmarks.py
+)
+
+pkg_postinst() {
+ ewarn "Version 2.10.x has significant API and implementation changes from"
+ ewarn "previous 2.9.x releases. Please read the documentation at"
+ ewarn "https://construct.readthedocs.io/en/latest/transition210.html"
+ ewarn "for more info."
+}