summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-06-26 18:50:08 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-26 18:56:25 +0200
commitdcbf6551b88706f39c3b1184633e863d659e2f36 (patch)
treea3fd86cf47b495a6d9804d635a73b9d1178dbe2c /dev-python/colorful
parentdev-libs/cudnn: bump 7.1.4 (diff)
downloadgentoo-dcbf6551b88706f39c3b1184633e863d659e2f36.tar.gz
gentoo-dcbf6551b88706f39c3b1184633e863d659e2f36.tar.bz2
gentoo-dcbf6551b88706f39c3b1184633e863d659e2f36.zip
dev-python/colorful: new package.
colorful is a Python module to print colored strings. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/colorful')
-rw-r--r--dev-python/colorful/Manifest1
-rw-r--r--dev-python/colorful/colorful-0.4.1.ebuild23
-rw-r--r--dev-python/colorful/metadata.xml12
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/colorful/Manifest b/dev-python/colorful/Manifest
new file mode 100644
index 000000000000..39c37757a7c9
--- /dev/null
+++ b/dev-python/colorful/Manifest
@@ -0,0 +1 @@
+DIST colorful-0.4.1.tar.gz 19696 BLAKE2B 9229200853d3050ebe61817fcfd975444a6568cbd490798c8bb2fdf3bb0286f7263d40942bb5edb28f64c6dd28e7a02cab5939d562bd2b091c05232efc3ac37f SHA512 41ce1c35193ebd8fa22bc06afb5536d02cdfc6bde89068693f6ddd1fec140f8823dafab10cf40496f48cb38ad87f874edd6819446b824028575030160b0adc7c
diff --git a/dev-python/colorful/colorful-0.4.1.ebuild b/dev-python/colorful/colorful-0.4.1.ebuild
new file mode 100644
index 000000000000..846c46b1efc5
--- /dev/null
+++ b/dev-python/colorful/colorful-0.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminal string styling done right in Python"
+HOMEPAGE="https://github.com/timofurrer/colorful"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ find "${ED}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/colorful/metadata.xml b/dev-python/colorful/metadata.xml
new file mode 100644
index 000000000000..cc035fa6a23a
--- /dev/null
+++ b/dev-python/colorful/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">colorful</remote-id>
+ <remote-id type="github">timofurrer/colorful</remote-id>
+ </upstream>
+</pkgmetadata>