summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-02 23:43:10 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-03 10:11:13 +0100
commit6c13ba82e533ccbe77adc64f8ec65bdff45d1ea9 (patch)
treef506ecf13889898d734b5759f4f3cabac14823d9 /dev-python/cmd2
parentdev-python/cloudpickle: Clean old up (diff)
downloadgentoo-6c13ba82e533ccbe77adc64f8ec65bdff45d1ea9.tar.gz
gentoo-6c13ba82e533ccbe77adc64f8ec65bdff45d1ea9.tar.bz2
gentoo-6c13ba82e533ccbe77adc64f8ec65bdff45d1ea9.zip
dev-python/cmd2: Clean old up
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/Manifest2
-rw-r--r--dev-python/cmd2/cmd2-0.6.7.ebuild25
-rw-r--r--dev-python/cmd2/cmd2-0.7.0.ebuild40
3 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index aa31fdf5d82b..b4a28f2b2ab8 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1,3 +1 @@
-DIST cmd2-0.6.7.tar.gz 20558 BLAKE2B cfc2f3dc111ddf225f3181a6c67af9a9c973f7e4d2ed9fefd3f7e5bcd82d1e8d3d3bd99b5a25aff17e591c11a80f57bf12f609b5434c17d4f239e9c54227c726 SHA512 a37393bd9ef6c3ece02249b5a4293a25889ebd68120ee592d2ccd77a8e3e4ab3ba724e0be7f3c98a453dbba30c1851c7f690fbe69711df8a723545f8dbe38607
-DIST cmd2-0.7.0.tar.gz 371786 BLAKE2B 0e705b85118ed3ddc870c0f161b74222e598b6e317037928e20799f9907b3a13c7dfaef0a5ed8d3d8c035283e8a0d6e55615a69528f1e5a6cf2fb85bc89fbc86 SHA512 13f9777908dabcbf9c81c0aea371c7c55e413616dfecc75b51b18e38b286656c9fc2b7368c859585a70d574c9c04413b1e65a5a58aa878f90283c31a54d49465
DIST cmd2-0.7.5.tar.gz 64939 BLAKE2B 57c8d3f4c7c94e8e2627fb5d2cf8c164da72c531808a53118f950ee79fcc2e0f431621ffbd74d275bf508c8646ded761d2d38c2b99570fdadbbaddf095e422a1 SHA512 14376ee283ac1c153ab0194a5dfa168eca36174783322ff72e190ed96b8c315518fef4f3ef09d77633851cb53b32f71fe380042ee3c0ef8ef2cbdfa16dabf704
diff --git a/dev-python/cmd2/cmd2-0.6.7.ebuild b/dev-python/cmd2/cmd2-0.6.7.ebuild
deleted file mode 100644
index 7b9f19dd3fd1..000000000000
--- a/dev-python/cmd2/cmd2-0.6.7.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Extra features for standard library's cmd module"
-HOMEPAGE="https://github.com/python-cmd2/cmd2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND=">=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- "${PYTHON}" -m cmd2 -v || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/cmd2/cmd2-0.7.0.ebuild b/dev-python/cmd2/cmd2-0.7.0.ebuild
deleted file mode 100644
index f78dccb5941f..000000000000
--- a/dev-python/cmd2/cmd2-0.7.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Extra features for standard library's cmd module"
-HOMEPAGE="https://github.com/python-cmd2/cmd2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Disable failing test
- [[ ${PV} == 0.7.0 ]] || die "Please remove the sed from python_prepare_all"
- sed -i -e 's:test_input_redirection:_&:' tests/test_cmd2.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -vv || die
- ${EPYTHON} example/example.py --test example/exampleSession.txt || die
-}