summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 08:14:44 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-13 09:20:04 +0100
commitdace3e6953cad521cab97766b4bad1699ab2e066 (patch)
tree6426e4f0640b153b1d1187ee1df5ead451c9c0cf /dev-python/cliff
parentdev-python/keystoneauth1: Bump to 5.5.0 (diff)
downloadgentoo-dace3e6953cad521cab97766b4bad1699ab2e066.tar.gz
gentoo-dace3e6953cad521cab97766b4bad1699ab2e066.tar.bz2
gentoo-dace3e6953cad521cab97766b4bad1699ab2e066.zip
dev-python/cliff: Bump to 4.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-4.5.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 6a1d66f9898e..2c43ee7b0cc1 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1 +1,2 @@
DIST cliff-4.4.0.tar.gz 83609 BLAKE2B dd17574bd91e501e664075e3e2f5fb0b37d64b8a6e0bbbc48b98eda0340d1f52340503f7ba85642c613672da41162e21cd248471ff6b028fbfc4142a491f482b SHA512 c1e292cd337036f3b276581022dd69cb7e353f1067be06db4611e1afb1fd613f70e8b67bbcd39eaf74e9c459af03f0f6e9613f9a1424941cc35b41ef1f62ae00
+DIST cliff-4.5.0.tar.gz 83722 BLAKE2B a610c65250cdf1ed33910408bdcde64a308c931d9e2c4d34d4b1b6e1c801354bf76833997b1672bf8b3cee54323da02baae479bf721a5ed507cfbc267c8c978d SHA512 e32f5c6f53a37306e79de79d3be653ea9fbe8581da6162578048f17188bb48d82a8108bd118cf34712601b08f53be80287c33929e07993c7363b09ad4f076d33
diff --git a/dev-python/cliff/cliff-4.5.0.ebuild b/dev-python/cliff/cliff-4.5.0.ebuild
new file mode 100644
index 000000000000..55704d1cacd3
--- /dev/null
+++ b/dev-python/cliff/cliff-4.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest