summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-26 12:42:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-26 12:42:41 +0200
commit8f925be3a87892ee53a7330fb6f19534af753241 (patch)
tree983d92f7417a6572eb5025397b24e6dc20a5e606 /dev-python/click/click-7.1.2.ebuild
parentdev-python/psutil: Fix one more test failure (diff)
downloadgentoo-8f925be3a87892ee53a7330fb6f19534af753241.tar.gz
gentoo-8f925be3a87892ee53a7330fb6f19534af753241.tar.bz2
gentoo-8f925be3a87892ee53a7330fb6f19534af753241.zip
dev-python/click: Bump to 7.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/click/click-7.1.2.ebuild')
-rw-r--r--dev-python/click/click-7.1.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/click/click-7.1.2.ebuild b/dev-python/click/click-7.1.2.ebuild
new file mode 100644
index 000000000000..e7dbf92c6e53
--- /dev/null
+++ b/dev-python/click/click-7.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="https://github.com/pallets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}