summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-07 17:52:30 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-07 19:26:40 +0200
commit3c30e7135fda94dbfeb492efae507ba50ec96b6d (patch)
tree10ab7390e43dab25aabd36e0518d9fb7ac8f394f /dev-python/cftime
parentdev-python/xarray: Handle missing dev-python/scipy gracefully (diff)
downloadgentoo-3c30e7135fda94dbfeb492efae507ba50ec96b6d.tar.gz
gentoo-3c30e7135fda94dbfeb492efae507ba50ec96b6d.tar.bz2
gentoo-3c30e7135fda94dbfeb492efae507ba50ec96b6d.zip
dev-python/cftime: Bump to 1.6.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cftime')
-rw-r--r--dev-python/cftime/Manifest1
-rw-r--r--dev-python/cftime/cftime-1.6.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/cftime/Manifest b/dev-python/cftime/Manifest
index 9b14f2bfdfea..5a8469ce6ea2 100644
--- a/dev-python/cftime/Manifest
+++ b/dev-python/cftime/Manifest
@@ -1 +1,2 @@
DIST cftime-1.6.3.tar.gz 53256 BLAKE2B 8875c368e6811487960fb240ed5320ab1dcc24f3678e9663e67b7c49ab8cc1f12a0030670760fcd1a15938b57f3860d5c9c9b30a3e5a0e1755fcd0c7b8deaf5f SHA512 0bcb8dcf7a840e500d7cc0f784f960b4972803f353fcffbf36dc30b2169b6864aea1fd8cab2d60e7908a063db55f2cfa3639c51fea84692b2dfe2d83b954c0ae
+DIST cftime-1.6.4.tar.gz 54615 BLAKE2B a986c3bc5eb1d45a31fcad849f621c9299f72c305fe29d75b50ff8c8be97e71032f306d1d33d29d4b58e8a31adfb23c552ed990026ea30ee4f34f3e2b4698dec SHA512 8b27859680a9fb1d3acc3bd95faab040b4571de40a07b327ea161a0dfad022a6c27008f74a4070c314c05e7237fd8574075e0c92d863dbcc81cd7f7d34e01399
diff --git a/dev-python/cftime/cftime-1.6.4.ebuild b/dev-python/cftime/cftime-1.6.4.ebuild
new file mode 100644
index 000000000000..e17368025cc6
--- /dev/null
+++ b/dev-python/cftime/cftime-1.6.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Time-handling functionality from netcdf4-python"
+HOMEPAGE="
+ https://github.com/Unidata/cftime/
+ https://pypi.org/project/cftime/
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~s390 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.26.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-python/cython-0.29.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -e "/--cov/d" -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}