summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-22 11:32:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-22 11:38:52 +0200
commit38824b0f84509e4128711d09144726c57cc15969 (patch)
tree2b7968a57183101be9b39c811914b1ec4ad69412 /dev-python/certifi
parentdev-python/pygobject: drop 3.48.2 (diff)
downloadgentoo-38824b0f84509e4128711d09144726c57cc15969.tar.gz
gentoo-38824b0f84509e4128711d09144726c57cc15969.tar.bz2
gentoo-38824b0f84509e4128711d09144726c57cc15969.zip
dev-python/certifi: Bump to 3024.7.22 (our own fork)
Closes: https://bugs.gentoo.org/936405 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/certifi')
-rw-r--r--dev-python/certifi/Manifest1
-rw-r--r--dev-python/certifi/certifi-3024.7.22.ebuild43
-rw-r--r--dev-python/certifi/metadata.xml1
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/certifi/Manifest b/dev-python/certifi/Manifest
index 25c84ad82105..a75342220c4c 100644
--- a/dev-python/certifi/Manifest
+++ b/dev-python/certifi/Manifest
@@ -1 +1,2 @@
DIST certifi-system-store-3021.3.16.gh.tar.gz 13784 BLAKE2B c0c2322fe298d363c4ef4dada2c0db8837bf7a32d86a7b54a1b45bb3dd3c99d732b2612f25495f4a59d9692f896e2b962e7057fa5fec9998724476db48f90c2a SHA512 44953ed8a3deb5fa4aff3f74afa557219e042acea395e9cdebfd26fd43ce0bdeca07c6b6dfe91977f88852e7674b94337b93c4d78fd2da6f47a6187fa46d6668
+DIST certifi-system-store-3024.7.22.gh.tar.gz 12441 BLAKE2B 445477dc557f980c5f2edf37d6683204181071e625dac66e9cc3bdeec38ba28ff385d2a92d8162de6af30fc552b64b6c8ad13a06dd6e7f2e26f02d453d69d5c4 SHA512 a4862dbb9f931322f7c62ecd877bee97679cc147acd4585642cbd215f37663f3bde7a73cf846bb0c84077c6cee1c1e4c06da9e2ce44d8dcb1e8fe6065e282feb
diff --git a/dev-python/certifi/certifi-3024.7.22.ebuild b/dev-python/certifi/certifi-3024.7.22.ebuild
new file mode 100644
index 000000000000..b37fdc72723e
--- /dev/null
+++ b/dev-python/certifi/certifi-3024.7.22.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+MY_P=certifi-system-store-${PV}
+DESCRIPTION="A certifi hack to use system trust store on Linux/FreeBSD"
+HOMEPAGE="
+ https://github.com/projg2/certifi-system-store/
+ https://github.com/tiran/certifi-system-store/
+ https://pypi.org/project/certifi-system-store/
+"
+SRC_URI="
+ https://github.com/projg2/certifi-system-store/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ app-misc/ca-certificates
+"
+
+EPYTEST_IGNORE=(
+ # requires Internet
+ tests/test_requests.py
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e "s^/etc^${EPREFIX}/etc^" src/certifi/core.py || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/certifi/metadata.xml b/dev-python/certifi/metadata.xml
index db64a2b878fe..980216c62a74 100644
--- a/dev-python/certifi/metadata.xml
+++ b/dev-python/certifi/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
+ <remote-id type="github">projg2/certifi-system-store</remote-id>
<remote-id type="github">tiran/certifi-system-store</remote-id>
<remote-id type="pypi">certifi-system-store</remote-id>
</upstream>