summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-11 12:24:32 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-11 12:28:17 +0100
commit5b160e143d36f6dd8871bc45adc2cf9cd9df7838 (patch)
tree4de389e687136bfc8500c47e815d8a3a2a706766 /dev-python/cerberus/files
parentdev-lang/ispc: remove upstreamed -Werror patch for live ebuild (diff)
downloadgentoo-5b160e143d36f6dd8871bc45adc2cf9cd9df7838.tar.gz
gentoo-5b160e143d36f6dd8871bc45adc2cf9cd9df7838.tar.bz2
gentoo-5b160e143d36f6dd8871bc45adc2cf9cd9df7838.zip
dev-python/cerberus: initial import
Dependency of Ansible Molecule. Builds, tests and installs fine on all implementations listed in PYTHON_COMPAT. Adding 1.3.2 in spite of it not being the latest upstream version because 1.3.3 and 1.3.4 are known to be broken, see https://github.com/pyeve/cerberus/issues/568 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/cerberus/files')
-rw-r--r--dev-python/cerberus/files/cerberus-1.3.2_no-pytest-runner.patch13
-rw-r--r--dev-python/cerberus/files/cerberus-1.3.2_test-installation.patch11
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/cerberus/files/cerberus-1.3.2_no-pytest-runner.patch b/dev-python/cerberus/files/cerberus-1.3.2_no-pytest-runner.patch
new file mode 100644
index 000000000000..b9216385d64c
--- /dev/null
+++ b/dev-python/cerberus/files/cerberus-1.3.2_no-pytest-runner.patch
@@ -0,0 +1,13 @@
+--- a/setup.py
++++ b/setup.py
+@@ -11,9 +11,7 @@
+ LONG_DESCRIPTION = open("README.rst").read()
+ VERSION = "1.3.2"
+
+-setup_requires = (
+- ["pytest-runner"] if any(x in sys.argv for x in ("pytest", "test", "ptr")) else []
+-)
++setup_requires = []
+
+
+ setup(
diff --git a/dev-python/cerberus/files/cerberus-1.3.2_test-installation.patch b/dev-python/cerberus/files/cerberus-1.3.2_test-installation.patch
new file mode 100644
index 000000000000..381822f1799f
--- /dev/null
+++ b/dev-python/cerberus/files/cerberus-1.3.2_test-installation.patch
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -35,7 +35,7 @@
+ ),
+ license="ISC",
+ platforms=["any"],
+- packages=find_packages(),
++ packages=find_packages(exclude=("cerberus.tests",)),
+ include_package_data=True,
+ setup_requires=setup_requires,
+ tests_require=["pytest"],