summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-09-14 22:00:28 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-09-14 22:00:28 -0400
commit6baba224f4e357d69b021309d730d29089be4f6d (patch)
treec953d4d22f0b1de2ba23883267a75f5cae4890c7 /dev-python/celery
parentdev-python/celery: tighten kombu dep constraint (diff)
downloadgentoo-6baba224f4e357d69b021309d730d29089be4f6d.tar.gz
gentoo-6baba224f4e357d69b021309d730d29089be4f6d.tar.bz2
gentoo-6baba224f4e357d69b021309d730d29089be4f6d.zip
dev-python/celery: remove old
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-python/celery')
-rw-r--r--dev-python/celery/Manifest1
-rw-r--r--dev-python/celery/celery-4.0.2.ebuild112
-rw-r--r--dev-python/celery/files/celery-3.1.19-test.patch16
-rw-r--r--dev-python/celery/files/celery-4.0.2-log-endless-loop.patch22
-rw-r--r--dev-python/celery/files/celery-docs.patch19
5 files changed, 0 insertions, 170 deletions
diff --git a/dev-python/celery/Manifest b/dev-python/celery/Manifest
index 6d8d87366329..788948c4524e 100644
--- a/dev-python/celery/Manifest
+++ b/dev-python/celery/Manifest
@@ -1,2 +1 @@
-DIST celery-4.0.2.tar.gz 1337804 BLAKE2B b040ada555d02c2c943ac86211b06d03e738db586fc811fed5cf6c6c1a4d6945c909e04444170da4d00dfd0f874b0723bff1f18d01ab8d557f989edaadfe03c9 SHA512 1110b634cafa13f9d9ab0b0a7a17042325271bd5ea45a5f442e36e871db87b87e3f496d54b771d274a1676900d9dfdc7e21887943dfd1a299a9fcd8b3f6d2189
DIST celery-4.1.0.tar.gz 1331689 BLAKE2B ac134d26a21bfd1172ea7a2ccc5f9934b4fdf56dccb6f840726040adf5b81ab0c675c0c93754340c0429c4eb5777a344be74415a795a9dd6654578979609cecd SHA512 5232adc43ba55d01f2b030382075750033e0c5c2abdc8308903e0cef7a465513b7765e2ae495da6555b377452ae233500530ef9d57e584a5352a54c5f4731c64
diff --git a/dev-python/celery/celery-4.0.2.ebuild b/dev-python/celery/celery-4.0.2.ebuild
deleted file mode 100644
index 762d6dc8a342..000000000000
--- a/dev-python/celery/celery-4.0.2.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 bash-completion-r1
-
-DESCRIPTION="Asynchronous task queue/job queue based on distributed message passing"
-HOMEPAGE="http://celeryproject.org/ https://pypi.org/project/celery/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# There are a number of other optional 'extras' which overlap with those of kombu, however
-# there has been no apparent expression of interest or demand by users for them. See requires.txt
-IUSE="doc examples redis sqs test yaml"
-
-RDEPEND="
- <dev-python/kombu-5.0[${PYTHON_USEDEP}]
- >=dev-python/kombu-4.0.2[${PYTHON_USEDEP}]
- >=dev-python/billiard-3.5.0.2[${PYTHON_USEDEP}]
- <dev-python/billiard-3.6.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- dev-python/vine[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/gevent[$(python_gen_usedep python2_7)]
- >=dev-python/pymongo-2.6.2[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/redis-py[${PYTHON_USEDEP}]
- >=dev-db/redis-2.8.0
- >=dev-python/boto-2.13.3[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-13.1.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
- >=dev-python/unittest2-0.5.1[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/docutils[${PYTHON_USEDEP}]
- >=dev-python/sphinx_celery-1.3[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' python2_7 python3_4)
- )"
-
-# testsuite needs it own source
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=(
- "${FILESDIR}"/${P}-log-endless-loop.patch
- )
-
-python_compile_all() {
- if use doc; then
- mkdir docs/.build || die
- emake -C docs html
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- # Main celeryd init.d and conf.d
- newinitd "${FILESDIR}/celery.initd-r2" celery
- newconfd "${FILESDIR}/celery.confd-r2" celery
-
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- newbashcomp extra/bash-completion/celery.bash ${PN}
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "zookeeper support" dev-python/kazoo
- optfeature "msgpack support" dev-python/msgpack
- #optfeature "rabbitmq support" dev-python/librabbitmq
- #optfeature "slmq support" dev-python/softlayer_messaging
- optfeature "eventlet support" dev-python/eventlet
- #optfeature "couchbase support" dev-python/couchbase
- optfeature "redis support" dev-db/redis dev-python/redis-py
- optfeature "couchdb support" dev-db/couchdb dev-python/couchdb-python
- optfeature "gevent support" dev-python/gevent
- optfeature "auth support" dev-python/pyopenssl
- optfeature "pyro support" dev-python/pyro:4
- optfeature "yaml support" dev-python/pyyaml
- optfeature "memcache support" dev-python/pylibmc
- #optfeature "threads support" dev-python/threadpool
- optfeature "mongodb support" dev-python/pymongo
- optfeature "sqlalchemy support" dev-python/sqlalchemy
- optfeature "sqs support" dev-python/boto
- #optfeature "cassandra support" dev-python/pycassa
-}
diff --git a/dev-python/celery/files/celery-3.1.19-test.patch b/dev-python/celery/files/celery-3.1.19-test.patch
deleted file mode 100644
index 25b41456a0ce..000000000000
--- a/dev-python/celery/files/celery-3.1.19-test.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-https://github.com/celery/celery/commit/fb48b1f357f7a416d1413d0056158a74191185af.diff
-diff --git a/celery/tests/backends/test_mongodb.py b/celery/tests/backends/test_mongodb.py
-index f7546d3..a32d9ed 100644
---- a/celery/tests/backends/test_mongodb.py
-+++ b/celery/tests/backends/test_mongodb.py
-@@ -253,8 +253,8 @@ def test_restore_group(self, mock_get_database):
- mock_collection.find_one.assert_called_once_with(
- {'_id': sentinel.taskset_id})
- self.assertItemsEqual(
-- ['date_done', 'result', 'task_id'],
-- list(ret_val.keys()),
-+ list(sorted(['date_done', 'result', 'task_id'])),
-+ list(sorted(ret_val.keys())),
- )
-
- @patch('celery.backends.mongodb.MongoBackend._get_database')
diff --git a/dev-python/celery/files/celery-4.0.2-log-endless-loop.patch b/dev-python/celery/files/celery-4.0.2-log-endless-loop.patch
deleted file mode 100644
index bf9396e45a39..000000000000
--- a/dev-python/celery/files/celery-4.0.2-log-endless-loop.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 9c950b47eca2b4e93fd2fe52cf80f158e6cf97ad Mon Sep 17 00:00:00 2001
-From: George Psarakis <giwrgos.psarakis@gmail.com>
-Date: Mon, 23 Jan 2017 11:49:38 +0200
-Subject: [PATCH] AWS DynamoDB result backend (#3736)
-
-* Fix endless loop in logger_isa (Python 3.6)
-
-https://github.com/celery/celery/pull/3736#issuecomment-274155454
-
-diff --git a/celery/utils/log.py b/celery/utils/log.py
-index 2fb15e6..00df476 100644
---- a/celery/utils/log.py
-+++ b/celery/utils/log.py
-@@ -82,7 +82,7 @@ def logger_isa(l, p, max=1000):
- else:
- if this in seen:
- raise RuntimeError(
-- 'Logger {0!r} parents recursive'.format(l),
-+ 'Logger {0!r} parents recursive'.format(l.name),
- )
- seen.add(this)
- this = this.parent
diff --git a/dev-python/celery/files/celery-docs.patch b/dev-python/celery/files/celery-docs.patch
deleted file mode 100644
index 5e09718feb2c..000000000000
--- a/dev-python/celery/files/celery-docs.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-# Prevent un-needed objects.inv files
-diff -ur celery-3.0.19.orig/docs/conf.py celery-3.0.19/docs/conf.py
---- docs/conf.py 2013-04-15 22:51:46.000000000 +0800
-+++ docs/conf.py 2013-04-27 21:46:25.070423582 +0800
-@@ -74,14 +74,6 @@
- # If true, '()' will be appended to :func: etc. cross-reference text.
- add_function_parentheses = True
-
--intersphinx_mapping = {
-- 'python': ('http://docs.python.org/dev', None),
-- 'kombu': ('http://kombu.readthedocs.org/en/latest/', None),
-- 'djcelery': ('http://django-celery.readthedocs.org/en/latest', None),
-- 'cyme': ('http://cyme.readthedocs.org/en/latest', None),
-- 'amqp': ('http://amqp.readthedocs.org/en/latest', None),
--}
--
- # The name of the Pygments (syntax highlighting) style to use.
- pygments_style = 'colorful'
-