summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-11-06 12:55:05 +0100
committerFabian Groffen <grobian@gentoo.org>2021-11-06 12:55:21 +0100
commit8a0cedf4aa0659957d96b9735bb79baad67a3bf0 (patch)
treeec0540f307a4de4a9af4795380bce95d2ab89c2e /dev-python/carbon
parentRevert "dev-python/inotify_simple: initial commit" (diff)
downloadgentoo-8a0cedf4aa0659957d96b9735bb79baad67a3bf0.tar.gz
gentoo-8a0cedf4aa0659957d96b9735bb79baad67a3bf0.tar.bz2
gentoo-8a0cedf4aa0659957d96b9735bb79baad67a3bf0.zip
dev-python/carbon-1.1.8: version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-python/carbon')
-rw-r--r--dev-python/carbon/Manifest1
-rw-r--r--dev-python/carbon/carbon-1.1.8.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/carbon/Manifest b/dev-python/carbon/Manifest
index 50aa1134d2e9..cde50d25126e 100644
--- a/dev-python/carbon/Manifest
+++ b/dev-python/carbon/Manifest
@@ -1 +1,2 @@
DIST carbon-1.1.7.tar.gz 73380 BLAKE2B 8f9c807bc5e1c6fc020ae31179b6c0c11724b1110def323f92e158c5cf7c88291686bdc7f9078fb9234e5f2877fd745f7ec581533fa9a77e0307bf56f8ba60e0 SHA512 f0c5c64fa02cfd5940a7b23dbb3f2af27f67595e301ae719f4e2e9cdb48d4a5673d36a60adc8d338a55202f8e89873a7539c960cc16649903305191c6b0fc875
+DIST carbon-1.1.8.tar.gz 72452 BLAKE2B d76a281925645ebf6f74ff83f8ea6a52016f29ae0e35143e48e9aa0f2fcc267ceee1b5040ad756bbab8b2c1ffde5040231b8e0b581bd177bfb31ddf33fab7933 SHA512 b679d0329a5c8701af8aad3bdc51d64fbab7d05214c09368a218f1c925593002596a04b50fd2aadf26bd21ea7ef4b8262ae7f8169ef0d6ee40dccbc933539161
diff --git a/dev-python/carbon/carbon-1.1.8.ebuild b/dev-python/carbon/carbon-1.1.8.ebuild
new file mode 100644
index 000000000000..ae7b292a9cd4
--- /dev/null
+++ b/dev-python/carbon/carbon-1.1.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Backend data caching and persistence daemon for Graphite"
+HOMEPAGE="https://graphiteapp.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+# whisper appears to have been missed from listing in install_requires in setup.py
+RDEPEND="
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/cachetools[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ =dev-python/whisper-${PV}*[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Do not install the configuration and data files. We install them
+ # somewhere sensible by hand.
+ sed -i -e '/data_files=install_files,/d' setup.py || die
+ # We want FHS-style paths instead of /opt/graphite
+ export GRAPHITE_NO_PREFIX=yes
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/carbon
+ doins conf/*
+
+ keepdir /var/log/carbon /var/lib/carbon/{whisper,lists,rrd}
+
+ newinitd "${FILESDIR}"/carbon.initd2 carbon-cache
+ newinitd "${FILESDIR}"/carbon.initd2 carbon-relay
+ newinitd "${FILESDIR}"/carbon.initd2 carbon-aggregator
+
+ newconfd "${FILESDIR}"/carbon.confd carbon-cache
+ newconfd "${FILESDIR}"/carbon.confd carbon-relay
+ newconfd "${FILESDIR}"/carbon.confd carbon-aggregator
+}
+
+pkg_postinst() {
+ einfo 'This ebuild installs carbon into FHS-style paths.'
+ einfo 'You will probably have to set GRAPHITE_CONF_DIR to /etc/carbon'
+ einfo 'and GRAPHITE_STORAGE_DIR to /var/lib/carbon to make use of this'
+ einfo '(see /etc/carbon/carbon.conf.example).'
+ einfo ' '
+ einfo 'OpenRC init script supports multiple instances !'
+ einfo 'Example to run an instance b of carbon-cache :'
+ einfo ' ln -s /etc/init.d/carbon-cache /etc/init.d/carbon-cache.b'
+ einfo ' cp /etc/conf.d/carbon-cache /etc/conf.d/carbon-cache.b'
+}