summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-08 15:05:50 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-08 15:18:45 +0200
commit610552dc857e60ee07e21464b3272abc19970e15 (patch)
tree5274ccd3ca0083be39f05ede2d09703e21475e80 /dev-python/capturer
parentdev-python/humanfriendly: enable py3.10 (diff)
downloadgentoo-610552dc857e60ee07e21464b3272abc19970e15.tar.gz
gentoo-610552dc857e60ee07e21464b3272abc19970e15.tar.bz2
gentoo-610552dc857e60ee07e21464b3272abc19970e15.zip
dev-python/capturer: enable py3.10 and disable py3.7, use epytest
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/capturer')
-rw-r--r--dev-python/capturer/capturer-3.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/capturer/capturer-3.0.ebuild b/dev-python/capturer/capturer-3.0.ebuild
index 5e5bb588b34f..cfb2c8736a4c 100644
--- a/dev-python/capturer/capturer-3.0.ebuild
+++ b/dev-python/capturer/capturer-3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
@@ -23,5 +23,5 @@ distutils_enable_sphinx docs
distutils_enable_tests pytest
python_test() {
- pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
+ epytest ${PN}/tests.py
}