summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-23 07:56:41 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-23 08:34:27 +0100
commitaecefad096659ade29fc6dc92422a47cc69e879c (patch)
treec84aecb2030692f89208acede12f36ad5e20da98 /dev-python/cachetools
parentdev-python/hypothesis: Bump to 6.64.0 (diff)
downloadgentoo-aecefad096659ade29fc6dc92422a47cc69e879c.tar.gz
gentoo-aecefad096659ade29fc6dc92422a47cc69e879c.tar.bz2
gentoo-aecefad096659ade29fc6dc92422a47cc69e879c.zip
dev-python/cachetools: Bump to 5.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cachetools')
-rw-r--r--dev-python/cachetools/Manifest1
-rw-r--r--dev-python/cachetools/cachetools-5.3.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/cachetools/Manifest b/dev-python/cachetools/Manifest
index 60670a24364a..0b882de3b733 100644
--- a/dev-python/cachetools/Manifest
+++ b/dev-python/cachetools/Manifest
@@ -1,2 +1,3 @@
DIST cachetools-5.2.0.tar.gz 27342 BLAKE2B 905986bca98996fbc74c74bc5710b429ae63b4bf6283a3910e83a92cac461ef4a0271b1691a694fe8ecacf38eeeb921d7345c9e015f1400705662081d5e29dbd SHA512 e12766aef1725091edcdd0ef3687b891242f711de069c0d0642680d61dcca79e645e6ecb5f2e22470f189aba59daa2b5a830dc76791256517368f8912a065eef
DIST cachetools-5.2.1.tar.gz 27401 BLAKE2B 0923744627c83b3c8d5d657730bcb44efbcb211076edb09d4b93149d7ee6856724a818c84ffcc048184060543dfca45f0c136d126143553d461515adda956e10 SHA512 3d86f1ff07f048576d7f7dc44954a7a469ac982e670f9e2ebec6f2a13ae741c9c06b8334e345d81ef8b69ae069056ab715dbea81c9f6fde7a7ff8b283bd7dca4
+DIST cachetools-5.3.0.tar.gz 27935 BLAKE2B 6ef41ef383aebc1d65e2855c6ce2e62ea38163b44f9dca756482ee8f35bbee033b88a3d7d458ea970fafb062f8b202563d478ff3ccae376f424bc643c9dcbe1a SHA512 5f0be2e95b82de4866718744ba1712354b413441eb8978f0bcb3e32306b6671b8ed7fa238aa31bef4c3b97764347d12a375b058f5df51dc80b277bf2cef23e61
diff --git a/dev-python/cachetools/cachetools-5.3.0.ebuild b/dev-python/cachetools/cachetools-5.3.0.ebuild
new file mode 100644
index 000000000000..b2389ae9952f
--- /dev/null
+++ b/dev-python/cachetools/cachetools-5.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extensible memoizing collections and decorators"
+HOMEPAGE="
+ https://github.com/tkem/cachetools/
+ https://pypi.org/project/cachetools/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest