summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-01-22 22:55:52 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-01-22 23:00:37 +0100
commitfe5b17a038b7ab896d7af8afec395a6c1ba8d4e7 (patch)
tree358e79f08588052c77f7eec351c7478794389cd3 /dev-python/botocore
parentdev-lang/gdl: Revbump post dep change (diff)
downloadgentoo-fe5b17a038b7ab896d7af8afec395a6c1ba8d4e7.tar.gz
gentoo-fe5b17a038b7ab896d7af8afec395a6c1ba8d4e7.tar.bz2
gentoo-fe5b17a038b7ab896d7af8afec395a6c1ba8d4e7.zip
dev-python/botocore: bump to v1.13.50
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.13.50.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index ec12523a5e9e..24aa5f5a5066 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -12,3 +12,4 @@ DIST botocore-1.13.28.tar.gz 5881818 BLAKE2B 9ec33e256a1dd09be0951e880947eaa9394
DIST botocore-1.13.36.tar.gz 6029078 BLAKE2B 83cccf74c368f9ee5292b8f880545582f220518491924d65991618a505649e795e89cae0f898c63e9b140afc4d2ff1a4861447e827d8a915e44412b7534ddbb8 SHA512 6b342a4a9c473a8c818b1de8fc799d746de9642b67d43d8da2e6eac8d4263b9300609359c22ea553c30dbe37ec64e8760934a5b21f8f25de71868cd88c4e1878
DIST botocore-1.13.44.tar.gz 6063673 BLAKE2B fc13c068f1173789188ce0d6c7b51294bb4a1ff2a1ce4823e20481ba2ea7e30972161e6f3439a1047f135259c5f10fbe5755b9301682fca9a5c7c882b363386f SHA512 1720dd64bc245e66bbda1c9c7369f16f3870c6cb9f2908e6ffa5bc4c6c211acc5e922d45bee2c13dc44665e5b69738b920f15a02572631804a6625cbe82d331e
DIST botocore-1.13.46.tar.gz 6069713 BLAKE2B 9d10fc46314f379ed384f2803d4bf43b10e73607e4f8d29a2edd0c067a3df5f2473175d70276c24939e24393d496b9875c4509ae7644b42d0899e5627c660f21 SHA512 71c60edef4f49f88a52305568f9b177ab8fbb9048203b3f7cba85dd676e4a3fc02f2ba0b07afabb6598d7e8f6d6703446325275f1fb54209e57ee51d1e3b2a8e
+DIST botocore-1.13.50.tar.gz 6076129 BLAKE2B c969ba8635970eb7613124cafa3f7d1efaeec22699857405450a5e669f19733cf3328839d8dc568b7b46d0e2c05a3a649d97805dcb50e047c455bfbb9fc32901 SHA512 8c7fb409f9d1cd47f2711cc5cd34e7459087b50cd257d4f943b475d195ac141e01c3be53194cdb045d6ccf4ea59fdb2e485899275bb3185e6e562318615ec14b
diff --git a/dev-python/botocore/botocore-1.13.50.ebuild b/dev-python/botocore/botocore-1.13.50.ebuild
new file mode 100644
index 000000000000..58b2573e49f4
--- /dev/null
+++ b/dev-python/botocore/botocore-1.13.50.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}