summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-22 07:23:45 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-22 08:48:32 +0100
commit8e7bcc9ef1e456c4657f3cc3b4b3d971428a24a0 (patch)
treedc71866ea0e3f5e7717827d318ac579632f003b9 /dev-python/botocore
parentnet-libs/pjproject: Stabilize 2.13.1 x86, #917659 (diff)
downloadgentoo-8e7bcc9ef1e456c4657f3cc3b4b3d971428a24a0.tar.gz
gentoo-8e7bcc9ef1e456c4657f3cc3b4b3d971428a24a0.tar.bz2
gentoo-8e7bcc9ef1e456c4657f3cc3b4b3d971428a24a0.zip
dev-python/botocore: Bump to 1.32.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.32.5.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index f26e0ec0127c..58d6a1d75309 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,3 +6,4 @@ DIST botocore-1.32.1.gh.tar.gz 12098630 BLAKE2B 3a2501da4bd2ec8d29f032a2df4d7946
DIST botocore-1.32.2.gh.tar.gz 12148168 BLAKE2B 29a70ed37526b8b5e3439a183b194d350505dd4ad0ac1e5d2ff729be29813b4b99b2b0806ca2f20a776efdcefc2b46295432af281e026ecf014fe45d5317c528 SHA512 775c5076e691605d6efe392e5565b84314ed7c93300ea394e5598ee34f4bb9e708a2c8479fbd646fdb619d36e0122fd4f6854e9ed40430c069677345bd76e335
DIST botocore-1.32.3.gh.tar.gz 12176739 BLAKE2B b119a54fb4770757c8f2c75b7404e009be1c7b35598d8a97e892aa644bbcc301b5f6bb44fa0f37bc8f4523af5ca9771daeda877937e640dd557038c8283967e1 SHA512 398127e140edc33750553f33a14cdc140048f5ee03c162705c6681b9bf08d871c9ba29f824ba2b6f1b11592260c6f0614ab4c06464cdda98172e8ca81bce73e9
DIST botocore-1.32.4.gh.tar.gz 12176332 BLAKE2B 0b0c2b1b481f88b23dad830f22dee4a79e947705a7b975cfda8f33e0154554eda930bf6e9f2d8e96b639706ae62c7b3b880e210d61e480afcd66f24375a4e754 SHA512 b3f8202a9144be2b7fa3d4030816d87a88959cb0d8340d100038e2d5c115071d272337d1570f1ff19d372bdd70a8d2643fb2e86f286e9a1d466cf0c8d84f9a1f
+DIST botocore-1.32.5.gh.tar.gz 12199009 BLAKE2B 6d48adf8f75089e366a775dd678c07c87d92eefe0194ce5b04e02333563325adf08b0dfb0c7e66a063dd43ad5d70f4aac7f2d91a3e5fee8a8a94e75b058ce560 SHA512 f55548b3473f8f9894b1d6404c66eafe8fd53952ab21ef56b8f243cbd16cabfa52460d63bec2981036c6f8e1d1c7ae5ab85e0ac629b29b6198925aed330fb6e1
diff --git a/dev-python/botocore/botocore-1.32.5.ebuild b/dev-python/botocore/botocore-1.32.5.ebuild
new file mode 100644
index 000000000000..05766e84276c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.32.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}