summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-02 07:45:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-02 08:25:34 +0200
commitb1e6c83f92cb4164d4a2f7306a6d9ea6c440a45c (patch)
treef40500667dbdf4c66935aeecd114f13a97a46706 /dev-python/boto3
parentdev-python/elementpath: Bump to 2.3.0 (diff)
downloadgentoo-b1e6c83f92cb4164d4a2f7306a6d9ea6c440a45c.tar.gz
gentoo-b1e6c83f92cb4164d4a2f7306a6d9ea6c440a45c.tar.bz2
gentoo-b1e6c83f92cb4164d4a2f7306a6d9ea6c440a45c.zip
dev-python/boto3: Bump to 1.18.34
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.34.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index d40428e0374b..d62e2ed534bf 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -10,4 +10,5 @@ DIST boto3-1.18.30.tar.gz 407362 BLAKE2B 14cbd75f3a4441d0b0aa3cb9cd1001053be5908
DIST boto3-1.18.31.tar.gz 407465 BLAKE2B 816833b83f8a9da0ce97ebd5a2636f8d7a9f9170c690c2be57be53f959f191976d2e661057a64b233705dfeb740c599520bf99cc74d385c867192e442cbb1076 SHA512 4dbe54b0beda32f3decbfe378cffc6c20899d4800196c4bf1390365ea0c84836b526f4a23cd2779a3cc365cc863612ade972c96284be7bbfbe8f652b1312c9c4
DIST boto3-1.18.32.tar.gz 407959 BLAKE2B 6e186599707ab606ab45b05347bfcc512e16c6c4d9793d002aa239eb0d1a0c0ee9e50a05013c7bd0e5b30c05e791646f692faf997e3ee6b35f278bfe888f16f1 SHA512 7b9862a9ca0d9e13e14d45d1cd989abc5e12e45e9f5cff1e52805c0bd39cbd8f27d5c24df5438e27c0a7e3115bb572570656ca09d5a58d93244802464864b38c
DIST boto3-1.18.33.tar.gz 408557 BLAKE2B 3912205ec8f8ac2687e23c5a3a973d97489baf2df18aea4b1e8dcf8a14ee4157a249583bf487416ba93bd1b52c595f6661ea00a8a6bc861103dc72edd0f1a5d4 SHA512 0ca253a138e6539c95bacb23f39ebd06dedaff3793a04bb92fe70b460a16e0e420cd3d9a35c7d3800af11ab1efe4bd369caecec26e81d2557bc5b0932b095d28
+DIST boto3-1.18.34.tar.gz 408795 BLAKE2B d3960f1479796a0b47dc4d5137efead974f1e9cd658ccc62391673b50809e45007e26a9f6fcded9e1ec79d3b26668e6aeadfbbfed38f63ecb98ec75cf2f0182d SHA512 4537b404c20b76922a407513a1ddbc594f8e948635e73d74ee4e7324f6c7f8855b0931f1fd8f7d9ce68c794cd44544876d1e23bc5cac78289eac53c675c2d4c7
DIST boto3-1.18.7.tar.gz 395640 BLAKE2B 6a9fa1dd55644806fe93271805f35fbe0c4cb65d1de08dded2d2f57fcefa96e32c4ebe7b60743c52c0898222bc06d33dbd03d304bbef327b88022450a7943e2c SHA512 20e7fedab7d061ab02f391e9baf36cb554e7f194f38d24d5a75f76715b2acf1b51b6adce5d8cf5a2a0d29df73566db00b8813a219d45a194d9a8eb93d0dab570
diff --git a/dev-python/boto3/boto3-1.18.34.ebuild b/dev-python/boto3/boto3-1.18.34.ebuild
new file mode 100644
index 000000000000..819e73691110
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.34.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ ||
+ die "test failed under ${EPYTHON}"
+}