summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-06 04:02:55 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-06 11:24:54 +0200
commit7d8541b03c13faf8a7e7e7556b42735cb633e19f (patch)
tree39cec9cbc0690dd35042d7b1a6d39f8fdcc2f938 /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.13 (diff)
downloadgentoo-7d8541b03c13faf8a7e7e7556b42735cb633e19f.tar.gz
gentoo-7d8541b03c13faf8a7e7e7556b42735cb633e19f.tar.bz2
gentoo-7d8541b03c13faf8a7e7e7556b42735cb633e19f.zip
dev-python/boto3: Bump to 1.35.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.13.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 58f305326986..3dc3df59024d 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,4 +2,5 @@ DIST boto3-1.35.0.gh.tar.gz 851637 BLAKE2B 485b17616fed53a88280aad92d2e4219d8bcb
DIST boto3-1.35.10.gh.tar.gz 856679 BLAKE2B 03e7be74455b487a79188405796fc08bd940962ca4ef8c36398ee8f955c2677e57a528626ef31e5e54ce2c1b96c82cef857b54dcc16248178c60c14fd14de3f9 SHA512 99c0e0b67a590a06713eeb98eb485b055ee6fa1bd181f996d24bdf88698d7885efe0a5f1e9883083655b12a474112a03f8561c66c4c5b5a0e6db56d5733db77b
DIST boto3-1.35.11.gh.tar.gz 857616 BLAKE2B ffec2fc8c2a0c12d21ac84e6cbe0ea967e83aab3764720046dcbb16ad7af6bcb8fcefe1e5686be0b2442cb0ebe58c5b5e9b3c41c38292069b0115c7d6cd00616 SHA512 4b6a494737be338ef81581de6372605bb75c99dcd83bb905af460d50deb3c2cbb929f0f89cf46e53d92dd302eb387baf7c0d898e5aecf96bafc8b099c75a9e0b
DIST boto3-1.35.12.gh.tar.gz 858007 BLAKE2B bdf0110d9bf0f6a0c9804a6cc69d2d5d6f7593cfd6fd6a62cf3ab57ef9ba6715fe9e8a12cff8d9d750df78b22e0ab15a667b7f2189634e1a736b7017f5301a03 SHA512 6eb42fed0d33c51675888c0f0bf0b325a766433263fd700b68e75c0d3b1996b449de4f92052e581981629a073a571ab741cc337edab052600b29d4e20d9d6027
+DIST boto3-1.35.13.gh.tar.gz 858752 BLAKE2B 9ca6c8a06bfe3d9db9f57a584e63f44253645fa76864b490ad05bafc2c93370fc8787e508525cd2db20a325912e73e99984cb6ccdc42759e81bffe6ecb0a39e6 SHA512 c30581554be7a5a770fee01ff3230c6546cbff167acf8795cfe81ffc6501b3e59df0162077c7b720cb41224ce412b06ed7b9a868a934dc780e87acf6bf5806e6
DIST boto3-1.35.5.gh.tar.gz 854016 BLAKE2B f94d738e310725cd5f9c7b405a094155f3ecf640f02045662ed94ab3689ea549fde7eee19ae2be450768560ad705b8740fda78b79ed42cf536231626d247e09a SHA512 fc1106abbb306bacb80dce825bf71303e71b0d0698d7e3bb4dcaca4ea6e4f7a97e70753367200294f334b351e764bca57f2316afec854d2e46db4644dfefc25b
diff --git a/dev-python/boto3/boto3-1.35.13.ebuild b/dev-python/boto3/boto3-1.35.13.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.13.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}