summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-25 00:13:10 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-25 01:02:45 +0100
commit522d096178294e7420446c2459d0c908a61186db (patch)
tree2a10b364ea61a7c9723176b416ea42eca62b09b0 /dev-python/boto3
parentdev-python/botocore: Bump to 1.24.26 (diff)
downloadgentoo-522d096178294e7420446c2459d0c908a61186db.tar.gz
gentoo-522d096178294e7420446c2459d0c908a61186db.tar.bz2
gentoo-522d096178294e7420446c2459d0c908a61186db.zip
dev-python/boto3: Bump to 1.21.26
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.21.26.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index b46f40585cc0..cfd15d2b6512 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,4 +1,5 @@
DIST boto3-1.21.15.tar.gz 476516 BLAKE2B 306c7ee69dec5ff1fbd76ed32aaebdf0f52cdc49df600562f49cd543e5f331c6dbf88001070022043b9fd01c651af83b1c8c0966292c90791831f2e9d9fc4a84 SHA512 9d431fcbdcd42658cd52094b97c151fd10a68f2c83a457dccdf7991c8358c17b32faa09e3941f6d6e72bad8cda1b93dcfae8d78585dae43790c0ec248f0ab15d
DIST boto3-1.21.22.tar.gz 479768 BLAKE2B 3ae647a4c06cb9f7c4c32216dba439ce8bbf346fccf5a8651c08b398bcb7fdb0a4ac81c8d311625d0f50634b90c2f8a02160a19435db836ad05edf0d998a148d SHA512 583a49907339fdb8bb1deaec7683dad6bd0c2836a05cc317a8fc97a17e7b79fd114677fd6342cf6f96b1140bf1bcf9ca0fb1fd3af1c86600e6cfba5bbbf21ec2
DIST boto3-1.21.25.tar.gz 482117 BLAKE2B 7f4823fa6045addb4b4ed01e83d1095e9f56dac7c232c5cc744cd956ce0c9840bf70a2901cf4094b0b403ba38129529880b1f1c91d26e9d85db9ca714cfc447b SHA512 2571098f20054d09e691adef67f518321349a55ae3f6eaf3b4ae1d58eefe2e61c67f1bce79366dd017bbaa86e8ffebea12f0d22c712f0b00487fe39e169ce115
+DIST boto3-1.21.26.tar.gz 482624 BLAKE2B 19f38b86eab6363ff86febc9f7623def010314a70e3d88c405bf641a4cd0b2de390fb69f5205c5df2e7d71c80a31989efbc64c442bd02d3d2a5efb7ee937596d SHA512 85848df7f5863df5ddc97be29f734bbdff54d195d5d1e465b35f3693b8196c03422b9a8024a2ecdaead40a4ddd1742c06e9d2e5b90fd4de28dffd6609f209dfb
DIST boto3-1.21.8.tar.gz 473069 BLAKE2B f08f76fb9c4e56e6ba5624c885973599505769d7f9eea6e20a06e1a641768b1f7b108fc7293282a55bf4c7d2b62eb34853f46b8c3ada9afb8fc25624daa60c12 SHA512 23ed88dcaefe3224db05959251befaae4f03859bf00daf649db1e838e5fb92e01a6da4bee8083366d804404aac358df19d7e4552d6aaf39f9c4b371ccc7f9088
diff --git a/dev-python/boto3/boto3-1.21.26.ebuild b/dev-python/boto3/boto3-1.21.26.ebuild
new file mode 100644
index 000000000000..6fcba460ab1d
--- /dev/null
+++ b/dev-python/boto3/boto3-1.21.26.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}