summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-08 09:33:09 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-08 10:42:16 +0100
commit0d02def71fa25236e84b637e71c4779def23604d (patch)
tree92e6f623378f536ee7ddbc94286dbd2f0d27d937 /dev-python/boto3
parentdev-python/botocore: Bump to 1.23.50 (diff)
downloadgentoo-0d02def71fa25236e84b637e71c4779def23604d.tar.gz
gentoo-0d02def71fa25236e84b637e71c4779def23604d.tar.bz2
gentoo-0d02def71fa25236e84b637e71c4779def23604d.zip
dev-python/boto3: Bump to 1.20.50
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.20.50.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index f99ec54dd9c4..60678dd3b5c5 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.20.46.tar.gz 464857 BLAKE2B 40eb0f2c298821530028c84f90d8acd9757a4b6
DIST boto3-1.20.47.tar.gz 465774 BLAKE2B ab615d29d79b209671808770968c38c2ef26b83ae48d1e18c3129c2886a274ae8a9fc7680fa851f205c28161bd16b20eef075c1a6cdbc5cfaf835c7ead974313 SHA512 c3a84ba9df6670879605e9085ea7aa15077d9f1c30117de6e9cd9cbb427a6a06097a388feb80a0ebc7ad1f422a40df402986d3dc9b004abf5252dab16524c761
DIST boto3-1.20.48.tar.gz 466063 BLAKE2B 7ba92d1cfbd576d4262e0f99a9e9aa118747fbbe60caa703c14f24559d4c2312b3e7695c40b6555bd58f7beb248e7ecfcedd64bc84badb44cb96812c9537cabe SHA512 e80f2e54909a3a54e5eba9c9a75c0ccbb2ba3f8907dfec9563f50bef1be56b82b593ae0bc0ee0bfab1a7c993d4bbf0c624486822ef3cd93ef425f39205b628f0
DIST boto3-1.20.49.tar.gz 466426 BLAKE2B 82f2ed7f14576afd5a4d2dab91b99986904fef97b98460dce152e0806cb20e39b14975e4c3362c9d208c4dce9de3e7a4fa9fa60559aa0007ff735ce9e43995e4 SHA512 6ea92236726b9200a8b06f773483b0d6803585480cfad1f68eab227598ca86c3aa93cbeccec5338febc52eb48691f003c5983d52be56dd91e97735ddbfac7053
+DIST boto3-1.20.50.tar.gz 466795 BLAKE2B 662284de4654781391605fba93f401ec24300abab696c02146739598e9206598e92539ff9468f99b108d3ac00f72555945986e04e2b6625baace11b8f9b746ef SHA512 103a75edc907ea9a7ed5d08bb8a2f31b1360495a130d0492461956c0ec5c1e1b839187d9d9feaebf7eb06e2d367f9fcdc1c522c234be3314fceca7884651d54e
diff --git a/dev-python/boto3/boto3-1.20.50.ebuild b/dev-python/boto3/boto3-1.20.50.ebuild
new file mode 100644
index 000000000000..48ea5aa483a1
--- /dev/null
+++ b/dev-python/boto3/boto3-1.20.50.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}