summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/blosc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/blosc')
-rw-r--r--dev-python/blosc/Manifest3
-rw-r--r--dev-python/blosc/blosc-1.2.0.ebuild34
-rw-r--r--dev-python/blosc/blosc-1.2.1.ebuild34
-rw-r--r--dev-python/blosc/blosc-1.2.3.ebuild34
-rw-r--r--dev-python/blosc/metadata.xml18
5 files changed, 123 insertions, 0 deletions
diff --git a/dev-python/blosc/Manifest b/dev-python/blosc/Manifest
new file mode 100644
index 000000000000..a4ce221cbcb2
--- /dev/null
+++ b/dev-python/blosc/Manifest
@@ -0,0 +1,3 @@
+DIST blosc-1.2.0.tar.gz 221882 SHA256 d740c1bd6440c5fd7203006538b6c626361fba705ce9ce8f36c400ddb2f50fec SHA512 85db692d3a68ebeacaaf3759807c386e05a13fbad873379d13fc2f2b7470929a3e6cbe7f37c952740e412eecb2cb83bed194e0f4f7af1ef2c934d5478cd93ce1 WHIRLPOOL aa81df21b15382f388fe746a7f9ab0f2ec9eaf82c56bcbd19edb03fb73ce527c6ff70d30461440e27a4292fcdb9f1d43ce039a3a6c2d9b0101f1a4441d2e1a61
+DIST blosc-1.2.1.tar.gz 225560 SHA256 41de5b3a129cb145e192a0f3e62b09b74da311b0750ad50ffcd4aaf8fcf6cfbe SHA512 1ec017b17313ca788ae96a54cdf57a8c770dc5c6eb7b2d13ff94c0c44e9adbced28a22a17497bc748955d756a799305f603d64fd882cefb5cd8068b6b46e8667 WHIRLPOOL 7ba45764eb15f21f2cacee32cbfdd6083d5dd1dcdb88fb0614429dc75e4f1edd311e7127932371a706beee5293963498b5f0b8f194f9d188d8da390e8201d409
+DIST blosc-1.2.3.tar.gz 225781 SHA256 46f796ae1360b3f1580a16dc7f9f2b88b019b4f5f013bec3b84ca9ef6c859da8 SHA512 85b5280f1cbc2163e1115a365aa8a47a1ae496795558f53ed78b1e81ab661a4187d3557cf8890b2a33fd0052a6cc88ac60dc1ea7e382cbf601ed83b440900cc8 WHIRLPOOL d4fb113755b2f98cb1d56976d82a38af1b3bfa2011a26d4a154eb3e9f8af14fc3975f29b643439031ecbf92813126f89aebeda123f8156e2bcc0db45dc9da96a
diff --git a/dev-python/blosc/blosc-1.2.0.ebuild b/dev-python/blosc/blosc-1.2.0.ebuild
new file mode 100644
index 000000000000..cc9c556e97cd
--- /dev/null
+++ b/dev-python/blosc/blosc-1.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="High performance compressor optimized for binary data"
+HOMEPAGE="http://blosc.pydata.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-libs/c-blosc"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # remove forced sse2
+ sed -i "s|CFLAGS\.append(\"-msse2\")|pass|" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ nosetests -v || die
+}
diff --git a/dev-python/blosc/blosc-1.2.1.ebuild b/dev-python/blosc/blosc-1.2.1.ebuild
new file mode 100644
index 000000000000..cc9c556e97cd
--- /dev/null
+++ b/dev-python/blosc/blosc-1.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="High performance compressor optimized for binary data"
+HOMEPAGE="http://blosc.pydata.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-libs/c-blosc"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # remove forced sse2
+ sed -i "s|CFLAGS\.append(\"-msse2\")|pass|" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ nosetests -v || die
+}
diff --git a/dev-python/blosc/blosc-1.2.3.ebuild b/dev-python/blosc/blosc-1.2.3.ebuild
new file mode 100644
index 000000000000..54242f1311b3
--- /dev/null
+++ b/dev-python/blosc/blosc-1.2.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="High performance compressor optimized for binary data"
+HOMEPAGE="http://blosc.pydata.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-libs/c-blosc-1.3.5"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # remove forced sse2
+ sed -i "s|CFLAGS\.append(\"-msse2\")|pass|" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ nosetests -v || die
+}
diff --git a/dev-python/blosc/metadata.xml b/dev-python/blosc/metadata.xml
new file mode 100644
index 000000000000..be632b34fb65
--- /dev/null
+++ b/dev-python/blosc/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ blosc is a high performance compressor optimized
+ for binary data. It has been designed to transmit data to the
+ processor cache faster than the traditional, non-compressed, direct
+ memory fetch approach via a memcpy() OS call.
+ Blosc works well for compressing numerical arrays that contains data
+ with relatively low entropy, like sparse data, time series, grids with
+ regular-spaced values, etc.
+ python-blosc a Python package that wraps Blosc.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">blosc</remote-id>
+</upstream>
+</pkgmetadata>