summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 20:17:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-01 20:25:26 +0100
commitdee53f72dabf31b9a06431cccbf4eaf5fec881c5 (patch)
tree135ef181e1ba5a95c85d0b72d8da7e61b2c5dbb9 /dev-python/betamax-matchers
parentdev-python/python-markdown-math: 0.8-r1, bump EAPI8, add Python3.11 (diff)
downloadgentoo-dee53f72dabf31b9a06431cccbf4eaf5fec881c5.tar.gz
gentoo-dee53f72dabf31b9a06431cccbf4eaf5fec881c5.tar.bz2
gentoo-dee53f72dabf31b9a06431cccbf4eaf5fec881c5.zip
dev-python/betamax-matchers: EAPI 8, PEP517, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/betamax-matchers')
-rw-r--r--dev-python/betamax-matchers/betamax-matchers-0.4.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/betamax-matchers/betamax-matchers-0.4.0-r1.ebuild b/dev-python/betamax-matchers/betamax-matchers-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..63ff2f2aa9df
--- /dev/null
+++ b/dev-python/betamax-matchers/betamax-matchers-0.4.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A group of experimental matchers for Betamax"
+HOMEPAGE="
+ https://github.com/betamaxpy/betamax_matchers/
+ https://pypi.org/project/betamax-matchers/
+"
+SRC_URI="
+ https://github.com/betamaxpy/betamax_matchers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P/-/_}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/betamax-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.4.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest