summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-15 20:39:36 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-15 21:04:08 -0500
commit0d22f5726a5268b70f01b517bb18a3cc7f3c1365 (patch)
treeb05a8f1602698dbbb6d3526454f05331f62697cd /dev-python/beagle
parentdev-python/bandit: set DISTUTILS_USE_SETUPTOOLS=rdepend (diff)
downloadgentoo-0d22f5726a5268b70f01b517bb18a3cc7f3c1365.tar.gz
gentoo-0d22f5726a5268b70f01b517bb18a3cc7f3c1365.tar.bz2
gentoo-0d22f5726a5268b70f01b517bb18a3cc7f3c1365.zip
dev-python/beagle: set DISTUTILS_USE_SETUPTOOLS=rdepend
Closes: https://bugs.gentoo.org/748024 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/beagle')
-rw-r--r--dev-python/beagle/beagle-0.3.0.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/beagle/beagle-0.3.0.ebuild b/dev-python/beagle/beagle-0.3.0.ebuild
index 64fefecbcd9f..115720be57ac 100644
--- a/dev-python/beagle/beagle-0.3.0.ebuild
+++ b/dev-python/beagle/beagle-0.3.0.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
DESCRIPTION="Command line client for Hound, the code search tool."
@@ -16,9 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
+DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
>=dev-python/cliff-2.11.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.18.4[${PYTHON_USEDEP}]"