summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 00:07:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 00:07:31 +0100
commit103d1855e57041fa6286f541341c91d79c7da483 (patch)
treedc37f4f2195afe47f8c89ffce8616f05f57a4791 /dev-python/autobahn
parentdev-python/pytest-mock: Disable plugin autoloading during tests (diff)
downloadgentoo-103d1855e57041fa6286f541341c91d79c7da483.tar.gz
gentoo-103d1855e57041fa6286f541341c91d79c7da483.tar.bz2
gentoo-103d1855e57041fa6286f541341c91d79c7da483.zip
dev-python/autobahn: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autobahn')
-rw-r--r--dev-python/autobahn/autobahn-22.1.1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/autobahn/autobahn-22.1.1.ebuild b/dev-python/autobahn/autobahn-22.1.1.ebuild
index 0541f3e0f8c4..7ac3954a819b 100644
--- a/dev-python/autobahn/autobahn-22.1.1.ebuild
+++ b/dev-python/autobahn/autobahn-22.1.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 optfeature
MY_P=${PN}-$(ver_rs 3 -)
@@ -31,6 +31,7 @@ RDEPEND="
>=dev-python/txaio-21.2.1[${PYTHON_USEDEP}]
dev-python/cryptography[${PYTHON_USEDEP}]
>=dev-python/hyperlink-21.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
@@ -74,7 +75,7 @@ python_prepare_all() {
# remove twisted plugin cache regen in setup.py
# to fix tinderbox sandbox issue
- sed -e 's/regenerate Twisted plugin cache/DO NOT & in Gentoo\nexit()/' \
+ sed -e '/import/s:reactor:__importmustfail__:' \
-i setup.py || die
distutils-r1_python_prepare_all
@@ -83,7 +84,7 @@ python_prepare_all() {
python_test() {
einfo "Testing all, cryptosign using twisted"
local -x USE_TWISTED=true
- cd "${BUILD_DIR}"/lib || die
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
"${EPYTHON}" -m twisted.trial autobahn || die "Tests failed with ${EPYTHON}"
unset USE_TWISTED
@@ -92,7 +93,7 @@ python_test() {
epytest autobahn/wamp/test/test_wamp_{cryptosign,component_aio}.py
unset USE_ASYNCIO
- rm -f "${BUILD_DIR}"/lib/twisted/plugins/dropin.cache || die
+ rm -f twisted/plugins/dropin.cache || die
}
pkg_postinst() {