summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/audioread
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/audioread')
-rw-r--r--dev-python/audioread/Manifest1
-rw-r--r--dev-python/audioread/audioread-1.0.1.ebuild33
-rw-r--r--dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch30
-rw-r--r--dev-python/audioread/metadata.xml17
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/audioread/Manifest b/dev-python/audioread/Manifest
new file mode 100644
index 000000000000..3d813fa78106
--- /dev/null
+++ b/dev-python/audioread/Manifest
@@ -0,0 +1 @@
+DIST audioread-1.0.1.tar.gz 13004 SHA256 19d1a8c55b00875235a198cb9119c2163394000ebbb0f05a074a356f71a96b04 SHA512 18e9e696785fe2f1b1d6ad7fe64e2878bf490d72aef7500998bb48b0733b382cf0b171d26c5b1465947de1d5f6ded25e2b57947402c31a440e8f346722fdc533 WHIRLPOOL 9489c01f54135677a01d2511d80150bd5f134b8b08ee20b55f78f708a788e604c282f43ea5ffbc669f2a00b3c2ae14f9062fe6752b21e14d1c50f4d36c3e2c6b
diff --git a/dev-python/audioread/audioread-1.0.1.ebuild b/dev-python/audioread/audioread-1.0.1.ebuild
new file mode 100644
index 000000000000..d56ad322f7bc
--- /dev/null
+++ b/dev-python/audioread/audioread-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for decoding audio files using whichever backend is available"
+HOMEPAGE="http://pypi.python.org/pypi/audioread"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( dev-python/gst-python:0.10[${PYTHON_USEDEP}] dev-python/pymad media-video/ffmpeg )"
+
+PATCHES=(
+ "${FILESDIR}/0001-Use-the-print-function-instead-of-the-print-keyword.patch"
+ )
+
+pkg_postinst() {
+ elog "You might need to enable additional USE flags in backends to"
+ elog "decode some types of audio files. Priority of backends:"
+ elog " * gstreamer"
+ elog " * mad"
+ elog " * ffmpeg"
+}
diff --git a/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch b/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch
new file mode 100644
index 000000000000..8feb9d0ca9b6
--- /dev/null
+++ b/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch
@@ -0,0 +1,30 @@
+From 3f86133d37d5cc5c8712730de67c23b0d33ce082 Mon Sep 17 00:00:00 2001
+From: Simon Chopin <chopin.simon@gmail.com>
+Date: Tue, 14 May 2013 12:46:50 +0200
+Subject: [PATCH] Use the print() function instead of the print keyword
+
+Python3 doesn't have the `print foo` statement.
+---
+ audioread/gstdec.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/audioread/gstdec.py b/audioread/gstdec.py
+index 78285db..fa8078f 100644
+--- a/audioread/gstdec.py
++++ b/audioread/gstdec.py
+@@ -366,8 +366,8 @@ if __name__ == '__main__':
+ for path in sys.argv[1:]:
+ path = os.path.abspath(os.path.expanduser(path))
+ with GstAudioFile(path) as f:
+- print f.channels
+- print f.samplerate
+- print f.duration
++ print(f.channels)
++ print(f.samplerate)
++ print(f.duration)
+ for s in f:
+- print len(s), ord(s[0])
++ print(len(s), ord(s[0]))
+--
+1.8.1.5
+
diff --git a/dev-python/audioread/metadata.xml b/dev-python/audioread/metadata.xml
new file mode 100644
index 000000000000..9977a55b9020
--- /dev/null
+++ b/dev-python/audioread/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+Decode audio files using whichever backend is available. The library currently supports:
+ * Gstreamer via gst-python.
+ * MAD via the pymad bindings.
+ * FFmpeg via its command-line interface.
+ * The standard library wave and aifc modules (for WAV and AIFF files).
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">audioread</remote-id>
+ </upstream>
+</pkgmetadata>