summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-16 07:42:54 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-16 08:46:48 +0200
commit31a47cf96e3bf33e02eed29c27ae699af528195a (patch)
treec42d3c845695b49aa3fcb9af28def31076acf6c2 /dev-python/asyncstdlib
parentRename dev-python/{octave_kernel → octave-kernel} (diff)
downloadgentoo-31a47cf96e3bf33e02eed29c27ae699af528195a.tar.gz
gentoo-31a47cf96e3bf33e02eed29c27ae699af528195a.tar.bz2
gentoo-31a47cf96e3bf33e02eed29c27ae699af528195a.zip
dev-python/asyncstdlib: Bump to 3.12.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asyncstdlib')
-rw-r--r--dev-python/asyncstdlib/Manifest1
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.12.3.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/asyncstdlib/Manifest b/dev-python/asyncstdlib/Manifest
index 14d8c6e982dc..65125de336eb 100644
--- a/dev-python/asyncstdlib/Manifest
+++ b/dev-python/asyncstdlib/Manifest
@@ -1,3 +1,4 @@
DIST asyncstdlib-3.12.0.tar.gz 44339 BLAKE2B ed96b676d6136de510f8e6223096120da946788264d0cdfde77edbbd63b1a56fc6f38c7bd998dd3f3b4659264852d14f4ec613f4007dd5931f2674f6746ca5cc SHA512 07c1683cbc9421790d27c0e694cb3a6a544236aaf62a3300cc886f6bae7c7e9525c9d2a92add9aaa72fd17604c8de41750f11236b3a7497130a12613658cec90
DIST asyncstdlib-3.12.1.tar.gz 44779 BLAKE2B 98400f1524cfa627e6ba4c214bd60ba7884c9110eae00a1ce4f389745da78e310d759c4a2cbdfd1d821afa65d85d9f23fcbe4022c3b0c66fdf166579df42ebc6 SHA512 d3cb16333b9e1f20dd979a84d0561c2175926f565b7c7284a9cb5e75f09145717c558d2142e36af8396299e72765f65b749ccdc1e55a829e73e2ce89f3cd1f2f
DIST asyncstdlib-3.12.2.tar.gz 47005 BLAKE2B 502d99afa0c796c8d079b62f30217f634d4026c46cc2b89b64d4fa9424abc4a3a774767c9e6dd7d5c8ec36ed0b56eedc52d267d6ca4bae6728a23a0a250eff5f SHA512 344cb729d2ea5da197f161c335fd9aa44b42ab1a81780b475635944374447dbbb3a03f6dd69692dbb59b65529cabb1a188de8a05e5275f6ec4cb71d7748bc638
+DIST asyncstdlib-3.12.3.tar.gz 47118 BLAKE2B 83967dc89c0a5fab13ff5f3cebec739644ba16479bf661447c179b491897be0a5933f6ae724f942643d349cef8eaff66cf621c565459b1b8774e93bc51e472ee SHA512 239f0741a694f58e359422bce1e54f6f7e3b1522f10ed4cfd137f4cd8c9861156744d7efa98ab155dd0aa489dbdc452c095d60b77922c6b53177708a65a26d86
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.12.3.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.12.3.ebuild
new file mode 100644
index 000000000000..14c83f6e1cdb
--- /dev/null
+++ b/dev-python/asyncstdlib/asyncstdlib-3.12.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The missing async toolbox"
+HOMEPAGE="
+ https://github.com/maxfischer2781/asyncstdlib/
+ https://pypi.org/project/asyncstdlib/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest