summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/asyncio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/asyncio')
-rw-r--r--dev-python/asyncio/Manifest2
-rw-r--r--dev-python/asyncio/asyncio-3.4.2.ebuild21
-rw-r--r--dev-python/asyncio/asyncio-3.4.3.ebuild26
-rw-r--r--dev-python/asyncio/metadata.xml16
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/asyncio/Manifest b/dev-python/asyncio/Manifest
new file mode 100644
index 000000000000..80831c62bd2f
--- /dev/null
+++ b/dev-python/asyncio/Manifest
@@ -0,0 +1,2 @@
+DIST asyncio-3.4.2.tar.gz 179696 SHA256 f9cb785691c1c48e4537bdd26d189d56335cc80ce4a77a4301e077ab8adea880 SHA512 b56fd9b613ffee901f9db39152b8c6495383788fa4466c32acc7509072cae95ec86839ec04500f535ae86de90cadfb77bff37e32d11a5c4091d83c9e2eec7f28 WHIRLPOOL 6adc52f1683efc7b7f1bef8ac5676b211bf069536c85d3c0d519470a636f7ba9ce512d01def22884dd3b14e9a730ecdaadf9efe33e1912e2bd2fb5020573dee7
+DIST asyncio-3.4.3.tar.gz 204411 SHA256 83360ff8bc97980e4ff25c964c7bd3923d333d177aa4f7fb736b019f26c7cb41 SHA512 42077cbbae3d67e6e45224cc1996f1aaaff137cdc5c8679ba830fd66098d1e9d8c05e315c8d2ef1add2f504ab769bd339e5d8ae2f7532d423282baca2d383736 WHIRLPOOL c5ad9e02a5cfb71335e7ddf46039a3245ea9aad78c8d47e3712ea20aa21b1a01ce52ad31b6166357c4e43230f15cb566ab752ac3ae702d53111767b7b278ba44
diff --git a/dev-python/asyncio/asyncio-3.4.2.ebuild b/dev-python/asyncio/asyncio-3.4.2.ebuild
new file mode 100644
index 000000000000..0a3aeb70ac04
--- /dev/null
+++ b/dev-python/asyncio/asyncio-3.4.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="reference implementation of PEP 3156"
+HOMEPAGE="http://pypi.python.org/pypi/asyncio https://github.com/python/asyncio"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/asyncio/asyncio-3.4.3.ebuild b/dev-python/asyncio/asyncio-3.4.3.ebuild
new file mode 100644
index 000000000000..1c979f824292
--- /dev/null
+++ b/dev-python/asyncio/asyncio-3.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="reference implementation of PEP 3156"
+HOMEPAGE="http://pypi.python.org/pypi/asyncio https://github.com/python/asyncio"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} runtests.py || die
+ PYTHONASYNCIODEBUG=1 ${PYTHON} runtests.py || die
+}
diff --git a/dev-python/asyncio/metadata.xml b/dev-python/asyncio/metadata.xml
new file mode 100644
index 000000000000..b5e4ea712dd3
--- /dev/null
+++ b/dev-python/asyncio/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+reference implementation of PEP 3156
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">asyncio</remote-id>
+ <remote-id type="github">python/asyncio</remote-id>
+ </upstream>
+</pkgmetadata>