summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-19 14:06:11 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-19 14:06:18 +0200
commitfe495bbc504d4be6b183727ffcad148c40e1f7a1 (patch)
treea0044483dd0128b81ec2a794b910e1a1e959b97f /dev-python/astropy
parentapp-office/scribus: Patch merged upstream (diff)
downloadgentoo-fe495bbc504d4be6b183727ffcad148c40e1f7a1.tar.gz
gentoo-fe495bbc504d4be6b183727ffcad148c40e1f7a1.tar.bz2
gentoo-fe495bbc504d4be6b183727ffcad148c40e1f7a1.zip
dev-python/astropy: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/astropy')
-rw-r--r--dev-python/astropy/Manifest1
-rw-r--r--dev-python/astropy/astropy-1.0.5.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/astropy/Manifest b/dev-python/astropy/Manifest
index 880a83bdb563..b0d73717ac64 100644
--- a/dev-python/astropy/Manifest
+++ b/dev-python/astropy/Manifest
@@ -3,3 +3,4 @@ DIST astropy-0.3.2.tar.gz 6375740 SHA256 0b564870f5c198885d9bbb1b3d07e526439303f
DIST astropy-0.4.4.tar.gz 6939433 SHA256 8b2bc2a82b8de48e5ee247c52f20e6d9c32a801e338b3086e9cd39b5219e3389 SHA512 235cd2a9a48276872fd7bcdfe11a74809fef042b9e2caf9d493c804ac48340793fc1ba542327c2e10a94ac569365d6421544bcc7b7a842b50b638f4abc6ae0b0 WHIRLPOOL b947dbe718f02edd773e32a7922b67d7fba2d74ee06bc262defb5616f9cee5354105a3d5076e0e138cc0faa1fac65256550a63506e2fbb1e5f92a4326be0700f
DIST astropy-0.4.tar.gz 6906375 SHA256 bcb16f7e01d74851d43c13a372fd5e240014ae9bc695a87ed2e2693d36581aba SHA512 661c9a5ea01aa5b38737606df5fdceb1e59cd63d669db01cb18dc20939301b058f5a1696725f25a21f87798fd2457bc96e726c4b52f5bf2473236c0e423e8047 WHIRLPOOL 951af517a3d5612be9ed1a23684a48e750521723fb5b982947e0c08a0f80fc53a1adce36d055b47f1374ec28028d08d47a0258570c1b4075448a72f95a2d588a
DIST astropy-1.0.4.tar.gz 7693852 SHA256 c64be72f3246ef699d2e0627a757afc0d59701fc9533088a8be0de23e16595a9 SHA512 5f66f61c93ad88afd2f24fedf96d553688de3c9f2a926dca9b1037ff24b4fd83bd486b870a0abf3c9810ad4e3e902c64f8dfb7f023363d0677e233a21667dfcc WHIRLPOOL ab10edec3650cc39d82e0f023ab107e5b23e75a03cbf8e24b0e902f3700c78921f86983f89ff533c56d9f4bc3b9d0109d8ee57cd6450ab239845b8a403bc5c26
+DIST astropy-1.0.5.tar.gz 7641836 SHA256 701b7bfef0ab99a2b9d5c4796eb7021d7bbdac19b60ff244c5428e3ea78177d4 SHA512 fe0e34db1719b9659fc10f453c619d00174fd34956299c14a76dc6497ab83aa0276e21ab9122b38edea3e31583b75575573062bbd20c17d349dbb4d1c0362716 WHIRLPOOL 4d699f4f3f3ff1cdbc149985e2a0fc92e16180c64efee95ca68f7c870d6841421bc4d9709fada1a73e7753ac1528ea84a7a619e76cb952a41a538b786c2ee014
diff --git a/dev-python/astropy/astropy-1.0.5.ebuild b/dev-python/astropy/astropy-1.0.5.ebuild
new file mode 100644
index 000000000000..3a3666e1b901
--- /dev/null
+++ b/dev-python/astropy/astropy-1.0.5.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core functionality for performing astrophysics with Python"
+HOMEPAGE="http://astropy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-libs/expat-2.1.0:0=
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sci-astronomy/erfa-1.2:0=
+ >=sci-astronomy/wcslib-4.25:0=
+ >=sci-libs/cfitsio-3.350:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+ test? (
+ dev-libs/libxml2[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.4-disable_helper.patch"
+ "${FILESDIR}/${PN}-1.0.4-system-six.patch"
+ "${FILESDIR}/${PN}-1.0.4-system-pytest.patch"
+ "${FILESDIR}/${PN}-1.0.4-system-configobj.patch"
+ )
+
+python_prepare_all() {
+ export mydistutilsargs="--offline"
+ rm -r ${PN}_helpers || die
+ cp "${FILESDIR}"/astropy-ply.py astropy/extern/ply.py || die
+ rm -r cextern/{expat,erfa,cfitsio,wcslib} || die
+ #rm -rvf ${PN}/extern/* || die
+ #{configobj,{six,pytest,configobj}.py} || die
+
+ cat >> setup.cfg <<-EOF
+
+ [build]
+ use_system_libraries=1
+ EOF
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_export_best
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ py.test -vv -k "not test_web_profile" astropy || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}