summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-18 20:10:14 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-18 20:10:43 +0000
commit3764c9756bec480696e0ebbb7e9d6421d81da933 (patch)
tree10d28de6ea8e8144a0759a71ef08e429eb1a631b /dev-python/astropy
parentdev-java/java-config: Deal with java-config-wrapper the right way (diff)
downloadgentoo-3764c9756bec480696e0ebbb7e9d6421d81da933.tar.gz
gentoo-3764c9756bec480696e0ebbb7e9d6421d81da933.tar.bz2
gentoo-3764c9756bec480696e0ebbb7e9d6421d81da933.zip
dev-python/astropy: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/astropy')
-rw-r--r--dev-python/astropy/Manifest2
-rw-r--r--dev-python/astropy/astropy-1.1.1.ebuild88
-rw-r--r--dev-python/astropy/files/astropy-1.1.1-fix-wcs.patch15
-rw-r--r--dev-python/astropy/files/astropy-1.1.1-mark-kown-failures.patch99
4 files changed, 203 insertions, 1 deletions
diff --git a/dev-python/astropy/Manifest b/dev-python/astropy/Manifest
index 461d0b29b06c..f32eecc24a33 100644
--- a/dev-python/astropy/Manifest
+++ b/dev-python/astropy/Manifest
@@ -1,2 +1,2 @@
-DIST astropy-1.0.4.tar.gz 7693852 SHA256 c64be72f3246ef699d2e0627a757afc0d59701fc9533088a8be0de23e16595a9 SHA512 5f66f61c93ad88afd2f24fedf96d553688de3c9f2a926dca9b1037ff24b4fd83bd486b870a0abf3c9810ad4e3e902c64f8dfb7f023363d0677e233a21667dfcc WHIRLPOOL ab10edec3650cc39d82e0f023ab107e5b23e75a03cbf8e24b0e902f3700c78921f86983f89ff533c56d9f4bc3b9d0109d8ee57cd6450ab239845b8a403bc5c26
DIST astropy-1.0.6.tar.gz 7632331 SHA256 1a0190ad420323b9bd8f7b29995a39580d7d59c5329c825bb5abb52e2f7b936d SHA512 84e02204bc55d3bd6e0e891dc56ab218d1deb65882d5d771b3f80c2a11790f77c103b0c0d5537f1842d98f0d3ded19039c82482c15147edadac89e9707537b40 WHIRLPOOL b20e5c2e3677485eaf22c71c7e3461443d4a92bf7b0e649f5e0153e0b1d46741958e983b743aa30bf07ad971a0c865e53211963653ddf814a5d4362f36f07b02
+DIST astropy-1.1.1.tar.gz 8157305 SHA256 4d2e7a8bd5191a66d7e1a52beefb4a0b6f496a1e9e8212422613219cb514769f SHA512 bc3c370da32d5f0098dbfc2808dba9d4d4424d3dcfba4d7ffd84b39569387b79ad93086e10678c259237f9cfe1229725501d0dc4eba51c9d01a4cd8a72024fb4 WHIRLPOOL 5b40955f56e6f080ad93b224eabd345565ef9f5e7f5ccb00e2737bd714117bc9b35922a044fe4ccaddb9d30fa72e13dd560577392120bfbd0a9d10c8aaa5aa01
diff --git a/dev-python/astropy/astropy-1.1.1.ebuild b/dev-python/astropy/astropy-1.1.1.ebuild
new file mode 100644
index 000000000000..cbe12838cef2
--- /dev/null
+++ b/dev-python/astropy/astropy-1.1.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core functionality for performing astrophysics with Python"
+HOMEPAGE="http://astropy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-libs/expat-2.1.0:0=
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sci-astronomy/erfa-1.2:0=
+ >=sci-astronomy/wcslib-5:0=
+ >=sci-libs/cfitsio-3.360:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ >=dev-python/astropy-helpers-1.1[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+ test? (
+ dev-libs/libxml2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.4-system-six.patch"
+ "${FILESDIR}/${PN}-1.0.4-system-configobj.patch"
+ "${FILESDIR}/${PN}-1.1.1-fix-wcs.patch"
+ "${FILESDIR}/${PN}-1.1.1-mark-kown-failures.patch"
+)
+
+python_prepare_all() {
+ export mydistutilsargs="--offline"
+ export ASTROPY_USE_SYSTEM_PYTEST=True
+ rm -r ${PN}_helpers || die
+ cp "${FILESDIR}"/astropy-ply.py astropy/extern/ply.py || die
+ rm -r cextern/{expat,erfa,cfitsio,wcslib} || die
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ cat >> setup.cfg <<-EOF
+
+ [build]
+ use_system_libraries=1
+ EOF
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_export_best
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/astropy/files/astropy-1.1.1-fix-wcs.patch b/dev-python/astropy/files/astropy-1.1.1-fix-wcs.patch
new file mode 100644
index 000000000000..efb12737c19b
--- /dev/null
+++ b/dev-python/astropy/files/astropy-1.1.1-fix-wcs.patch
@@ -0,0 +1,15 @@
+Author: Kacper Kowalik <xarthisius.kk@gmail.com>
+Description: Copy keys to a list, since orignal map is modified
+Url: https://github.com/astropy/astropy/issues/4477
+Bug: https://github.com/astropy/astropy/issues/4460
+--- a/astropy/wcs/wcs.py
++++ b/astropy/wcs/wcs.py
+@@ -988,7 +988,7 @@
+ """
+ # Never pass SIP coefficients to wcslib
+ # CTYPE must be passed with -SIP to wcslib
+- for key in (m.group() for m in map(SIP_KW.match, header.keys())
++ for key in (m.group() for m in map(SIP_KW.match, list(header))
+ if m is not None):
+ del header[key]
+
diff --git a/dev-python/astropy/files/astropy-1.1.1-mark-kown-failures.patch b/dev-python/astropy/files/astropy-1.1.1-mark-kown-failures.patch
new file mode 100644
index 000000000000..2e2c82af5416
--- /dev/null
+++ b/dev-python/astropy/files/astropy-1.1.1-mark-kown-failures.patch
@@ -0,0 +1,99 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Mark all known test failures as xfail.
+ These failures have been discussed with upstream.
+--- a/astropy/io/fits/tests/test_connect.py
++++ b/astropy/io/fits/tests/test_connect.py
+@@ -136,6 +136,8 @@
+ # while reading is to check whether col.null is present. For float columns, col.null
+ # is not initialized
+
++# see https://github.com/astropy/astropy/issues/3415
++ @pytest.mark.xfail()
+ def test_read_from_fileobj(self, tmpdir):
+ filename = str(tmpdir.join('test_read_from_fileobj.fits'))
+ hdu = BinTableHDU(self.data)
+@@ -172,6 +174,8 @@
+ def setup_method(self, method):
+ warnings.filterwarnings('always')
+
++# see https://github.com/astropy/astropy/issues/3415
++ @pytest.mark.xfail()
+ def test_read(self, tmpdir):
+ filename = str(tmpdir.join('test_read.fits'))
+ self.hdus.writeto(filename)
+@@ -189,6 +193,8 @@
+ Table.read(filename, hdu=0)
+ assert exc.value.args[0] == 'No table found in hdu=0'
+
++# see https://github.com/astropy/astropy/issues/3415
++ @pytest.mark.xfail()
+ @pytest.mark.parametrize('hdu', [1, 'first'])
+ def test_read_with_hdu_1(self, tmpdir, hdu):
+ filename = str(tmpdir.join('test_read_with_hdu_1.fits'))
+--- a/astropy/wcs/wcs.py
++++ b/astropy/wcs/wcs.py
+@@ -84,6 +84,8 @@
+ if six.PY3 or platform.system() == 'Windows':
+ __doctest_skip__ = ['WCS.all_world2pix']
+
++# see https://github.com/astropy/astropy/issues/3380
++__doctest_skip__ = ['WCS.all_world2pix']
+
+ if _wcs is not None:
+ WCSBase = _wcs._Wcs
+--- a/astropy/tests/tests/test_socketblocker.py
++++ b/astropy/tests/tests/test_socketblocker.py
+@@ -66,8 +66,8 @@
+ def _square(x):
+ return x ** 2
+
+-
+-@pytest.mark.skipif('not PY3_4 or sys.platform == "win32" or sys.platform.startswith("gnu0")')
++# see https://github.com/astropy/astropy/issues/4193
++@pytest.mark.skipif(True, reason="Blocks on Debian CI test")
+ def test_multiprocessing_forkserver():
+ """
+ Test that using multiprocessing with forkserver works. Perhaps
+--- a/astropy/coordinates/tests/test_api_ape5.py
++++ b/astropy/coordinates/tests/test_api_ape5.py
+@@ -319,7 +319,8 @@
+ # coordinate object, and one that returns a cartesian matrix but does *not*
+ # require `newobj` or `fk5frame` - this allows optimization of the transform.
+
+-
++# Temporary mark until scipy/numpy is fully on 3.5
++@pytest.mark.xfail()
+ def test_highlevel_api():
+ J2001 = time.Time('J2001', scale='utc')
+
+--- a/astropy/visualization/tests/test_histogram.py
++++ b/astropy/visualization/tests/test_histogram.py
+@@ -50,6 +50,8 @@
+ assert patches2[0].axes is ax[1]
+
+
++# see https://github.com/astropy/astropy/issues/4329
++@pytest.mark.xfail()
+ @pytest.mark.skipif('not HAS_PLT')
+ def test_hist_autobin(rseed=0):
+ rng = np.random.RandomState(rseed)
+--- a/astropy/table/tests/test_info.py
++++ b/astropy/table/tests/test_info.py
+@@ -6,6 +6,7 @@
+ import warnings
+ import numpy as np
+
++from ...tests.helper import pytest
+ from ...extern import six
+ from ... import units as u
+ from ... import time
+@@ -225,7 +226,8 @@
+ t.info(out=out)
+ assert out.getvalue().splitlines() == exp
+
+-
++# see https://github.com/astropy/astropy/issues/4336
++@pytest.mark.xfail()
+ def test_ignore_warnings():
+ t = table.Table([[np.nan, np.nan]])
+ with warnings.catch_warnings(record=True) as warns: