summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-02-01 08:19:49 -0500
committerVirgil Dupras <vdupras@gentoo.org>2019-02-01 08:19:49 -0500
commit76a26b82ace3351e51ad18e4fcab2d5a96f516a0 (patch)
tree569050ea5cc1dcef1ed77d489c1cd28c149d5763 /dev-python/astroid/files
parentdev-java/jgoodies-looks-2.3.1-r1: fixed compilation with ant-1.9.13+ (diff)
downloadgentoo-76a26b82ace3351e51ad18e4fcab2d5a96f516a0.tar.gz
gentoo-76a26b82ace3351e51ad18e4fcab2d5a96f516a0.tar.bz2
gentoo-76a26b82ace3351e51ad18e4fcab2d5a96f516a0.zip
dev-python/astroid: disable pytest-runner
Makes build fail under network sandbox. Closes: https://bugs.gentoo.org/677042 Closes: https://bugs.gentoo.org/672628 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/astroid/files')
-rw-r--r--dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch b/dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch
new file mode 100644
index 000000000000..94eda1725457
--- /dev/null
+++ b/dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 2ad90aac..4628a40f 100644
+--- a/setup.py
++++ b/setup.py
+@@ -42,7 +42,6 @@ def install():
+ install_requires = install_requires,
+ extras_require=extras_require,
+ packages=find_packages(exclude=['astroid.tests']) + ['astroid.brain'],
+- setup_requires=['pytest-runner'],
+ test_suite='test',
+ tests_require=['pytest'],
+ )