summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-30 15:28:16 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-30 15:32:46 +0100
commit71bfd17e5c2889cd15f2b337395b4e34765f5258 (patch)
treeaf09928ea2f73b3133f2e17cd5f44aae0dddb054 /dev-python/argcomplete
parentdev-python/Babel: Remove old (diff)
downloadgentoo-71bfd17e5c2889cd15f2b337395b4e34765f5258.tar.gz
gentoo-71bfd17e5c2889cd15f2b337395b4e34765f5258.tar.bz2
gentoo-71bfd17e5c2889cd15f2b337395b4e34765f5258.zip
dev-python/argcomplete: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argcomplete')
-rw-r--r--dev-python/argcomplete/Manifest2
-rw-r--r--dev-python/argcomplete/argcomplete-3.1.6.ebuild43
-rw-r--r--dev-python/argcomplete/argcomplete-3.2.0.ebuild43
3 files changed, 0 insertions, 88 deletions
diff --git a/dev-python/argcomplete/Manifest b/dev-python/argcomplete/Manifest
index 56c681c62557..986f6ea33669 100644
--- a/dev-python/argcomplete/Manifest
+++ b/dev-python/argcomplete/Manifest
@@ -1,3 +1 @@
-DIST argcomplete-3.1.6.tar.gz 79685 BLAKE2B df21d5a68a173a3c09b76d866adf949910ad775eb6c7d09d797308e87c128a6eebe173d89fc95aaa42bb87bf08e9c84aa217e8844c9fab5c680c83e07d0c7854 SHA512 7d625dfc49253281f692254a23e7fc4af155b97a7df55a0b33eba9655281702396a1119269cf80b5650885e00d75886fbdcbd85312e7ccac6d940edd6189d50e
-DIST argcomplete-3.2.0.tar.gz 80524 BLAKE2B cbe15faf0c46f761204f004a4b630efbb037444a7222c9fcd59dafa7f2d8201edade374cf70fe3a059d3681ef320942dd3b43f0984c04a2cd52fe0571dafce6c SHA512 4ec4b83f68080cf8710b7377ae377a8ae10bc54f46bdd2a825b4c04d80a8d42f63fbc04d6413e2c430d7f4024ecd42f944b102c70e3fa3b60afda10a33994ac7
DIST argcomplete-3.2.1.tar.gz 80727 BLAKE2B 61964ebce499f64eda1e54ccfaf811d327fc1af4010d2365ccbc68809b336c079c32907bbbcea510658759f31eb22663876d655cd8d6126a3407740aa72c897a SHA512 6b6a42b0a1f7f4bfa27ce4ab756f1a665c4fdf4592af106908bbcfdd8af94ed1c4404ad602d9405f84abf011a474f191b36dc761aaeef8d18f2fbde71eba4f5e
diff --git a/dev-python/argcomplete/argcomplete-3.1.6.ebuild b/dev-python/argcomplete/argcomplete-3.1.6.ebuild
deleted file mode 100644
index bc91e38c6e93..000000000000
--- a/dev-python/argcomplete/argcomplete-3.1.6.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Bash tab completion for argparse"
-HOMEPAGE="
- https://github.com/kislyuk/argcomplete/
- https://pypi.org/project/argcomplete/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# pip is called as an external tool
-BDEPEND="
- test? (
- app-shells/fish
- app-shells/tcsh
- app-shells/zsh
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/pip-19
- )
-"
-
-PATCHES=(
- # increase test timeouts -- this is particularly necessary
- # for entry point tests because they read metadata of all installed
- # packages which can take real long on systems with lots of packages
- "${FILESDIR}/argcomplete-3.1.6-timeout.patch"
-)
-
-python_test() {
- "${EPYTHON}" test/test.py -v || die
-}
diff --git a/dev-python/argcomplete/argcomplete-3.2.0.ebuild b/dev-python/argcomplete/argcomplete-3.2.0.ebuild
deleted file mode 100644
index 691d9d9b7d84..000000000000
--- a/dev-python/argcomplete/argcomplete-3.2.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Bash tab completion for argparse"
-HOMEPAGE="
- https://github.com/kislyuk/argcomplete/
- https://pypi.org/project/argcomplete/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# pip is called as an external tool
-BDEPEND="
- test? (
- app-shells/fish
- app-shells/tcsh
- app-shells/zsh
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/pip-19
- )
-"
-
-PATCHES=(
- # increase test timeouts -- this is particularly necessary
- # for entry point tests because they read metadata of all installed
- # packages which can take real long on systems with lots of packages
- "${FILESDIR}/argcomplete-3.1.6-timeout.patch"
-)
-
-python_test() {
- "${EPYTHON}" test/test.py -v || die
-}