summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-12-09 00:44:41 -0500
committerTim Harder <radhermit@gentoo.org>2016-12-09 00:45:51 -0500
commitb301ef79018eed2402255adbe76e27b4eb754013 (patch)
tree313906707cb9ac39e031cd8e8c131f945cd314dd /dev-python/apsw
parentdev-python/setuptools: version bump to 30.3.0 (diff)
downloadgentoo-b301ef79018eed2402255adbe76e27b4eb754013.tar.gz
gentoo-b301ef79018eed2402255adbe76e27b4eb754013.tar.bz2
gentoo-b301ef79018eed2402255adbe76e27b4eb754013.zip
dev-python/apsw: version bump to 3.15.2_p1
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.15.2_p1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 450d8139b13f..77a8bfcb25c1 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -3,3 +3,4 @@ DIST apsw-3.13.0_p1.zip 692414 SHA256 1f8e337f88befb609427d468ee87c99da0b9477a9c
DIST apsw-3.14.1_p1.zip 693104 SHA256 e76f955bfa22bda7e46423218ba7ac8f460af3ebfe02faedd938600262c6798e SHA512 1f2a8c47a89656e3c3e2320185b0020ffd414aa28c9b9629b0504767b15c5ccded0e896ddc514f048ad9e0a5f262fbb6b945788ff215504fe1a72395a564becf WHIRLPOOL 0731ed3b38fe2c59b1dbdee9fa336bad49c1d1e69e8fb05383e50e2cbff05ce1798319c12f2ee00997c6010fb50441db8e1caf9781ca2b496d939e6fa17f24e4
DIST apsw-3.15.0_p1.zip 690750 SHA256 cac4d2afad9661892aafa46dcba19a6982f3fc56be7a48322e75660c4662b3d5 SHA512 eca4c5264334009feec56bbb25ff4285936ab4690e49309fc82abfa6e6a7ebfa62bbb4a773024f93f99f6fced7651ede2a431c118eca9918b458e90f6e626ae8 WHIRLPOOL 1a269548aae2396a0922602cd99f93488c5fdf3e1ad60ef4eb0111c3666d23952c8e613ccf1f93637e2f56730b8382f744188dd87983d76e4b8a86bc28fa0f8b
DIST apsw-3.15.1_p1.zip 690913 SHA256 8122431b7d8d698221e2544fefa7be9d50d440e183a52d7fad9ccc6cc8032a8b SHA512 4d0e83e2b956b0333a21c23fe1c44fc39f1dc9ef66c79e4c22de897afa5e2d7444ba35f04426255b3f2392d17a41d54d3cec48737f6de0fad151adac8ee568f8 WHIRLPOOL 1b338b54c382154326c6d4af1900203d18e296d837f2405973a118c4d0d04ee7cc36afdd354b177fd38d196c5cc8cb5c2dd5643d63eb317049893830d50c9c9b
+DIST apsw-3.15.2_p1.zip 691032 SHA256 840a5be3019ee50d37a216179b845095571c0aa7fc612902b7182f2249a092b9 SHA512 111ae410b30dcf0d3718d2898f93d315194eac51aa51f6920fdc09e4883178c0400b66e4916b3adb6da8ee16c71076cde1007d96aad38014ec89d3d4060ac137 WHIRLPOOL 5f313701283c73702bea973b4a18c0af1ae02013dca6b8d87b33a6e3ba574ad1018ff081f82e8c882c7d7368a002eb6e66507cbddb91aa8df01445e20639832a
diff --git a/dev-python/apsw/apsw-3.15.2_p1.ebuild b/dev-python/apsw/apsw-3.15.2_p1.ebuild
new file mode 100644
index 000000000000..7df79398d77c
--- /dev/null
+++ b/dev-python/apsw/apsw-3.15.2_p1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_p/-r}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="https://github.com/rogerbinns/apsw/"
+SRC_URI="https://github.com/rogerbinns/apsw/releases/download/${MY_PV}/${MY_P}.zip -> ${P}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-db/sqlite-${PV%_p*}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch" )
+
+python_compile() {
+ python_is_python3 || append-cflags -fno-strict-aliasing
+ distutils-r1_python_compile --enable=load_extension
+}
+
+python_test() {
+ "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
+ "${PYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}