summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/anyvc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/anyvc')
-rw-r--r--dev-python/anyvc/Manifest1
-rw-r--r--dev-python/anyvc/anyvc-0.3.7.1-r1.ebuild55
-rw-r--r--dev-python/anyvc/metadata.xml12
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/anyvc/Manifest b/dev-python/anyvc/Manifest
new file mode 100644
index 000000000000..8b6b79c78b01
--- /dev/null
+++ b/dev-python/anyvc/Manifest
@@ -0,0 +1 @@
+DIST anyvc-0.3.7.1.tar.gz 45890 SHA256 264ccd659269ff62ca983d48c7affd27194992880d094e32fff58225a9b6311c SHA512 90151133b4da41acb10c2d8e421963e5ccb1e8da1e5327d5a69a77ccc647086683f1ff8ef600c69e01cfda28193c69166fa5717af3dbd13761d95ab3f1c7be46 WHIRLPOOL 5f6500d069eafa56434d57c225e566e55aedadaad0c1d4afc7ff76c0481f3e797f6ea64e88d3001e06d6a529dc01d6c38cbb9e2324245c103d7031b7ef00278a
diff --git a/dev-python/anyvc/anyvc-0.3.7.1-r1.ebuild b/dev-python/anyvc/anyvc-0.3.7.1-r1.ebuild
new file mode 100644
index 000000000000..a287a9c465ae
--- /dev/null
+++ b/dev-python/anyvc/anyvc-0.3.7.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to access any version control system"
+HOMEPAGE="http://pypi.python.org/pypi/anyvc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="bazaar doc git mercurial subversion"
+
+RDEPEND="dev-python/apipkg[${PYTHON_USEDEP}]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ bazaar? ( dev-vcs/bzr )
+ git? ( dev-python/dulwich[${PYTHON_USEDEP}] )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-python/subvertpy )"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/hgdistver[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+# dev-python/hgdistver )"
+
+python_prepare_all() {
+ # Do not use unsupported theme options.
+ sed -e "/'tagline':/d" \
+ -e "/'bitbucket_project':/d" \
+ -i docs/conf.py
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html docs docs_output || die "Generation of documentation failed"
+ fi
+}
+
+python_install_all() {
+ if use doc; then
+ pushd docs_output > /dev/null
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/anyvc/metadata.xml b/dev-python/anyvc/metadata.xml
new file mode 100644
index 000000000000..8c0318f0aa77
--- /dev/null
+++ b/dev-python/anyvc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <use>
+ <flag name="bazaar">Add support for Bazaar</flag>
+ <flag name="mercurial">Add support for Mercurial</flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">anyvc</remote-id>
+ </upstream>
+</pkgmetadata>